USB view does not launch

Asked by krishnarajulu on 2018-07-02

On migrating to 18.04 I've had to install USB View in order to view USB devices (especially memory stick/USB drive).
I've been able to install it , but it doesn't launch

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
51 minutes ago
Last reply:
4 hours ago

Nautilus shows USB storage just fine. There is no need for an extra application.
What file system is the USB storage using please?
Before you unplug the storage physically, do you use the safe remove feature in your OS(es)?

Thanks

krishnarajulu (kkbandi) said : #2

Its usually the NTFS file system that I use in the USB storage. With 16.04 it was a simple "Plug & Play" and "Eject" unmounted the storage which could then be safely (physically) unplugged. Now, with 18.04, I'm not able to do this.

Thanks

You can safe remove in Nautilus.

I suggest you plug the device into a windows system and run a full chkdsk on the file system to make sure it is complete and consistent. NTFS is proprietary to Microsoft and only they know how it works. The NTFS access in Linux is a best effort attempt and having any issues in the file system will cause issues in non-Windows operating systems

Manfred Hampl (m-hampl) said : #4

For diagnostic purposes, what is the output of the commands (to be executed in a terminal window)

uname -a
lsb_release -crid
apt-cache policy usbview
lsusb

krishnarajulu (kkbandi) said : #5

In response to actionparsnip(andrew-woodhead666)

I've plugged the device(s) into a system running on Ubuntu 16.04 and everything is in order, that is, I can view all files/folders and can edit them etc. Also the devices get 'unmounted' using the "safely remove drive" command.

In response to Manfred Hampl(m-hampl)

uname -a
 : command not found

  lsb-release -crid
Distributor ID: Ubuntu
Description: Ubuntu 18.04 LTS
Release: 18.04
Codename: bionic

apt-cache policy usbview
usbview:
  Installed: 2.0-21-g6fe2f4f-1ubuntu1
  Candidate: 2.0-21-g6fe2f4f-1ubuntu1
  Version table:
 *** 2.0-21-g6fe2f4f-1ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe i386 Packages
        100 /var/lib/dpkg/status

lsusb
Bus 002 Device 006: ID 413c:8160 Dell Computer Corp. Wireless 365 Bluetooth
Bus 002 Device 005: ID 413c:8162 Dell Computer Corp. Integrated Touchpad [Synaptics]
Bus 002 Device 004: ID 413c:8161 Dell Computer Corp. Integrated Keyboard
Bus 002 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0c45:641d Microdia 1.3 MPixel Integrated Webcam
Bus 001 Device 003: ID 0461:4e54 Primax Electronics, Ltd
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Manfred Hampl (m-hampl) said : #6

"uname" is a standard function in Ubuntu (in the coreutils package). I am very surprised that you receive "command not found" for the command "uname -a". It seems that you are missing crucial programs.

krishnarajulu (kkbandi) said : #7

I tried uname -a again and this is what I got

Linux krishnarajulu-Inspiron-N5010 4.15.0-24-generic #26-Ubuntu SMP Wed Jun 13 08:44:45 UTC 2018 i686 i686 i686 GNU/Linux

I hope this is OK

Manfred Hampl (m-hampl) said : #8

Ok, it seems to me that the "command not found" was caused by a typo error, and apparently the standard programs are available in your system.

What happens if you open a terminal window and execute the command
usbview

Launchpad Janitor (janitor) said : #9

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.

krishnarajulu (kkbandi) said : #10

The problem is still not solved. Any device ( pen drive, external hard disk
etc) connected to any of my (working) USB ports does not open. This was not
the case when I was on 16.04

On Thu, 19 Jul 2018, 1:28 pm Launchpad Janitor, <
<email address hidden>> wrote:

> Your question #670602 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/670602
>
> Status: Needs information => Expired
>
> Launchpad Janitor expired the question:
> This question was expired because it remained in the 'Needs information'
> state without activity for the last 15 days.
>
> --
> If you're still having this problem, you can reopen your question either
> by replying to this email or by going to the following page and
> entering more information about your problem:
> https://answers.launchpad.net/ubuntu/+question/670602
>
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #11

What do you want to express when you say "device does not open"? Open in what sense?

What happens if you execute the command "usbview" in a terminal window?

krishnarajulu (kkbandi) said : #12

When the command "usbview" is executed in a terminal window, this is what I get

" cannot open the file /sys/kernel/debug/usb/devices

Verify that you have USB compiled into your kernel, have the USB core modules loaded, and have the usbdevfs filesystem mounted"

krishnarajulu (kkbandi) said : #13

When I say that the device does not open, it means that it is not automatically mounted and I can access the "contents"

Manfred Hampl (m-hampl) said : #14

Is automounting enabled?

What is the output of the command
gsettings list-recursively org.gnome.desktop.media-handling

krishnarajulu (kkbandi) said : #15

I dont know if automounting is enabled.

The output of the command is:

krishnarajulu@krishnarajulu-Inspiron-N5010:~$ gsettings list-recursively org.gnome.desktop.media-handling
org.gnome.desktop.media-handling automount-open true
org.gnome.desktop.media-handling automount true
org.gnome.desktop.media-handling autorun-x-content-start-app @as []
org.gnome.desktop.media-handling autorun-never false
org.gnome.desktop.media-handling autorun-x-content-ignore @as []
org.gnome.desktop.media-handling autorun-x-content-open-folder @as []

Manfred Hampl (m-hampl) said : #16

What happens if you do the following:

If the USB is connected to the system, remove (eject) the USB stick and wait a minute.
Insert the USB stick and wait a minute
Execute the command

dmesg | tail

and copy/paste the output that you receive into this question document.

krishnarajulu (kkbandi) said : #17

I did just that and here is the output

krishnarajulu@krishnarajulu-Inspiron-N5010:~$ dmesg | tail
[ 1689.283548] usb 2-1.2: Manufacturer: Kingston
[ 1689.283550] usb 2-1.2: SerialNumber: 60A44C4138F0BE11698B2140
[ 1698.418539] usb 2-1.2: USB disconnect, device number 7
[ 1704.277312] usb 2-1.2: new high-speed USB device number 8 using ehci-pci
[ 1704.392186] usb 2-1.2: New USB device found, idVendor=0951, idProduct=1666
[ 1704.392190] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1704.392192] usb 2-1.2: Product: DataTraveler 3.0
[ 1704.392193] usb 2-1.2: Manufacturer: Kingston
[ 1704.392195] usb 2-1.2: SerialNumber: 60A44C4138F0BE11698B2140
[ 1726.834567] usb 2-1.2: USB disconnect, device number 8

However, when I inserted the USB stick there was no indication that it got "mounted" and I could not get anything
 with a right-click to see the contents of the stick. "Dismounting" was by removing the stick.

Manfred Hampl (m-hampl) said : #18

The extract of the syslog in your posting shows that within half a minute the device was connected and disconnected twice.
This is not normal and can indicate a hardware problem (either with the stick or with the USB port of the system).

Is the USB stick directly connected, or via some extension cable or hub?

Do you see similar "USB disconnect" messages in the system log if you try plugging the USB stick to a different USB port, and/or do you see the same when using a different stick?

krishnarajulu (kkbandi) said : #19

I dont think there is anything wrong with the stick or the USB port(s).
The stick is directly connected/inserted to the USB port.

The syslog showed that the device was connected and disconnected twice because I had (inadvertently)
done just that.

I get similar "USB disconnect" messages in the syslog when the stick is plugged into different USB ports.

Can you help with this problem?

Provide an answer of your own, or ask krishnarajulu for more information if necessary.

To post a message you must log in.