18.04 livecd fails to boot acpi problem

Asked by k4lmcisme on 2018-06-10

The livecd fails to boot, hangs up with the following condition:

kernel panic ,not syncing. attempted to kill init, exitcode=0x 00000009

system locks. have to do power on reset to continue.

My machine:
Machine: System: ASUSTeK product: C51-MCP51
           Mobo: ASUSTek model: Pyrite v: 1.02
           Bios: Phoenix v: 3.05 date: 11/01/2006
CPU: Dual core AMD Athlon 64 X2 3800+ (-MCP-) cache: 1024 KB
           clock speeds: max: 2000 MHz 1: 1000 MHz 2: 1000 MHz
Graphics: Card: NVIDIA C51 [GeForce 6150 LE]
           Display Server: X.Org 1.18.4 driver: nvidia
           Resolution: 1600x1200@60.00hz
           GLX Renderer: GeForce 6150 LE/integrated/SSE2
           GLX Version: 2.1.2 NVIDIA 304.135
Audio: Card NVIDIA MCP51 High Definition Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.11.0-14-generic
Network: Card: NVIDIA MCP51 Ethernet Controller driver: forcedeth
           IF: enp0s20 state: up speed: 100 Mbps duplex: full
           mac: 00:18:f3:cc:3c:72
Drives: HDD Total Size: 1280.3GB (49.2% used)
           ID-1: /dev/sda model: WDC_WD6401AALS size: 640.1GB
           ID-2: /dev/sdb model: WDC_WD6401AALS size: 640.1GB
Partition: ID-1: / size: 98G used: 75G (80%) fs: ext4 dev: /dev/sdb5
           ID-2: swap-1 size: 2.08GB used: 0.09GB (5%) fs: swap dev: /dev/sdb6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 40.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 191 Uptime: 1:13 Memory: 1479.6/1933.3MB
           Client: Shell (bash) inxi: 2.2.35

Note: Also system will fail to boot in similar manner with any kernel later than 4.11 so this may be a kernel related problem. kernel 4.11 boots and runs with out any viable problems.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-06-14
Last query:
2018-06-14
Last reply:
2018-06-12

Try the boot option:

noacpi

I assume you MD5 tested the ISO you d

I assume you MD5 tested the ISO you downloaded or used torrents to get the file.

k4lmcisme (k4lmcisme) said : #3

The hash appears to be fine.

After looking further, and after discovering the use of the F6 key, I was able to boot the livecd with the noacpi option selected so it looks like the disk is OK.

My system is currently running with kernel 4.11. I tried installing kernel 4.13. The system will not boot under 4.13 either and fails with the same problem as the livecd. So it appears that nothing is wrong with the Ubuntu 18.04 livecd.

So it appears that I cannot use any kernel newer than 4.11 and cannot use the latest OS.

Do I need to post this problem in a different place since I would like to upgrade to latest OS.

Thanks for your prompt reply.

Manfred Hampl (m-hampl) said : #4

I suggest that you try installing the latest mainline kernel https://wiki.ubuntu.com/Kernel/MainlineBuilds
If this fails in a similar way, then create a bug report.

What you should also do is checking whether an updates BIOS version exists for your system and installing it if possible.

k4lmcisme (k4lmcisme) said : #5

All kernels newer than 4.11 fail to boot including the 18.04 livecd which appears to be based on kernel 4.15.

Not sure how to debug problem that fails so early in the boot process and locks up everything so that the only way to recover is to re-boot the system.

Have a jpg image of the screen when it fails but don't know how to insert the image with this message.

Best Manfred Hampl (m-hampl) said : #6

Have you already tried the newest (4.17) kernel (this would probably require installing an older Ubuntu release and then adding the newest kernel)?

As already suggested: create a bug report.
You can add pictures to a bug report, but not to a question document.

k4lmcisme (k4lmcisme) said : #7

This is what I was able to get using the 'tesseract" ocr program since I could not figure out how to send and image file.

 Get the same error booting from the system or the livecd of Ubuntu 18.04 and with any kernel above 4.11, which by the way boots and works fine.

Error condition on failure to boot:

 ---I end Kernel panic - not syncing:

..... faiied :(.
Kernel panic - not syncing: IO-APIC + timer doesn’t work!
Boot with apic=debug and send a report. Then try booting with 'noacpic' option.
CPU: 0 P1D: 1 Comm: swapper/0 Not tainted 4.13.0-13-generic x48~1.04.1-Ubuntu
Hardware name: ASUSTek Computer INC. C51-MCP51/Pyrite. BIOS 3.05 01/2006
Call Trace:
dump_stack+0x63/0x8b
panic+0xe4/0x24d
check_timer+0x59c/0x63e
? radix_tree_lookup+0xd/0x10
setup_10_APIC+0x1b7/0x1c4
apic_bsp_setup+0xb7/0xc8
native_smp_prepare_cpus+0x2bd/0x32d
kernel_init_freeabie+0xd2/0x23b
? rest_init+0xc0/0xc0
kernel_init+0xc/0xfc
ret_from_fork+0x35/0x40
---[ end Kernel panic - not syncing: IO-APIC timer doesn’t uork‘
Boot with apic+debug and send report. Then try booting uith the ’noapic’ option

The Livecd 'will' boot with the 'noapic' option using the F6 key at boot time. Afraid if I install 18.04 that it will not boot because of this error.

k4lmcisme (k4lmcisme) said : #8

currently running 16.04 version that fails on any kernel 4.13 and 4.15. Thanks for your response! Will close this question now and will proceed with as a bug when my time allows. Everything continues to work with 16.04 and kernel 4.11.014-generic x86_64.

Will try to pursue this further as time allows

Thank to everyone who helped.