Desktop icons don't open

Asked by Trevor Hickey on 2018-06-08

I'll try to be as detailed as I can be.
I installed Ubuntu 18.04 LTS, and installed it in vmware.
Then I switched over to gnome-fallback.
Desktop icons DO NOT open when I double left-click on the desktop.
I tried all the other desktop environment things. Metacity, Cinnamon, GNOME.. everything that I could choose.
They all had the same problem.

Right clicking on a folder shows "Open", "Open in New Window", "Open with Application".
"Open" and "Open in New Window" also had no effect.
If I click "Open with Application" its already selecting the default nautilus and clicking ok on that opens it correctly.
Yet, double clicking or using the two other mentioned menu items still can not open the folder.
I can open directories everywhere else but the desktop. If I drag a desktop icon to my toolbar, I can open it from there.
Once nautilus is already open, I can navigate fine.

I thought it must be something with mime/types and inode/directories.

gio mime inode/directory
Default application for “inode/directory”: nautilus-folder-handler.desktop
Registered applications:
 Thunar-folder-handler.desktop
 nautilus-folder-handler.desktop
Recommended applications:
 Thunar-folder-handler.desktop
 nautilus-folder-handler.desktop

I tried everything related to mime types. I set different defaults. I cleared caches.
I tried nemo. I tried Thunar, I tried just nautilus.desktop.
I edited the .desktop files to have support for gnome, but nothing seemed to work.

I followed the advice here:
https://askubuntu.com/questions/706672/how-to-set-default-opening-folder-for-nautilus-file-manager?utm_medium=organic&utm_source=google_rich_qa&utm_campaign=google_rich_qa
about editing .desktop files. I rebooted between all of these changes. Nothing seemed to work.

I discovered that this doesn't work with symlinks on the desktop either.
(maybe eorth mentioning as its a different mime type.

Then I installed and switched to xubuntu, and everything worked.
I'm convinced this has something to do with Ubuntu 18.04 LTS, because I've been installing and using previous versions and always doing the same setup without problems.

Let me know if I can provide more information

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2018-06-09
Last reply:
2018-06-25

What is the output of:

ls -la ~/Desktop/*.desktop; echo; whoami; lsb_release -a; uname -a

Thanks

ls -la ~/Desktop/*.desktop; echo; whoami; lsb_release -a; uname -a
zsh: no matches found: /home/thickey/Desktop/*.desktop

thickey
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04 LTS
Release: 18.04
Codename: bionic
Linux ubuntu 4.15.0-22-generic #24-Ubuntu SMP Wed May 16 12:15:17 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

I only have one user, which I made during installation.

This is not a very helpful reddit post, but it matches my problem exactly, and makes me think I'm not alone:
https://www.reddit.com/r/Ubuntu/comments/8je3s4/cant_open_desktop_folders_on_ubuntu_1804/

OK what is the output of:

ls -la ~/Desktop/*

Thanks

ls -al ~/Desktop
total 20
drwxr-xr-x 4 thickey thickey 4096 Jun 8 10:37 .
drwxr-xr-x 29 thickey thickey 4096 Jun 9 10:26 ..
drwxr-xr-x 4 thickey thickey 4096 Jun 6 13:28 folder1
drwxr-xr-x 4 thickey thickey 4096 Jun 8 10:37 folder2
-rw-r--r-- 1 thickey thickey 680 Jun 7 17:27 file

There isn't any .desktop files here or recursively. The permissions seem normal.
Switching to xubuntu worked, but gnome does not. Its something to do with the desktop interface, but I'm not sure where to look into that.

Launchpad Janitor (janitor) said : #7

This question was expired because it remained in the 'Open' state without activity for the last 15 days.