Ubuntu Server 18 Install Problem: curthooks?

Asked by Mike Dacre on 2018-06-04

Tried to install Ubuntu server on brand new Dell server, got a python traceback from curthooks.py, which seems to be called by unshare.

There is a very long traceback and error message, but I can't copy/save it because it is on a new machine with console access only.

Here are the highlights:

Unexpected error while running command: unshare --fork --pid -- chroot /target apt-get --quiet --option=Acquire::Languages=none --option=Dir::Etc::sourcelist=/tmp/tmpk_vnogkp/sources.list --option=Dir::Etc::sourceparts=/tmp/tmpk_vnogkp/sources.list.d update

Exit code: 100

finish: cmd-install: FAIL: curtin command install

Traceback:
  File "/usr/lib/python3/dist-packages/curtin/commands/curthooks.py", line 191, in install_kernel
    map_suffix = mapping[codename][version]
KeyError: 'bionic'

Picture of traceback:
Page 1: https://i.imgur.com/JccsbhZ.jpg
Page 2: https://i.imgur.com/lm7IuYq.jpg
Page 3: https://i.imgur.com/X1g3NRr.jpg

One thing I am not sure of is if the network is working yet, it may have issues, there seems to be a few messages in there regarding invalid online repositories.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-06-05
Last query:
2018-06-05
Last reply:
2018-06-05
Mike Dacre (mike.dacre) said : #1

The network was working. No idea what is causing this.

Mike Dacre (mike.dacre) said : #2

Just installed 16.04, that worked fine.

Mike Dacre (mike.dacre) said : #3

And then I got 18.04 working fine by just upgrading directly from 16.04, so it works now, but I think there is a bug in the 18.04 installer.

Did you MD5 test the ISO you downloaded?

Best Manfred Hampl (m-hampl) said : #5

I assume that the "unshare/curthooks" problem is caused by previous errors.

The error messages
"E: Release file for http://.../InRelease is not valid yet (invalid for another 2h 58min 50s)."
might indicate a time synchronization problem (the BIOS time settings on the server could have been wrong, causing the signatures on the repository data to appear invalid).

Mike Dacre (mike.dacre) said : #6

Yes, I did MD5 (and GPG) tested the ISO, I also tried both as a CD image and a USB image.

It is quite possible that the timestamp was the issue, I am not sure what the bios time was set to, it could have been off as it was a band new machine and I had never explicitly synced the bios clock.

Does the 18.04 installer not have any way of handling this? How did the 16.04 installer handle it? Because that installed just fine.

Unfortunately, I don't have a good way of testing this further as I need to get the server working and the 16.04->18.04 install path worked for me. I do think the issue should be fixed though, it seems a little silly that Ubuntu server would fail to install on a brand new Dell server. Possibly the installer should have a bios time clock sync step added before it queries the remote repositories?

Manfred Hampl (m-hampl) said : #7

You might consider creating a bug report.

Mike Dacre (mike.dacre) said : #8

Thanks Manfred Hampl, that solved my question.