Ubuntu 18.04 and Kubuntu 18.04 Suspend fails - change to kernel 4.14 fixes it

Asked by pHeLiOn

Ubuntu and Kubuntu 18.04 have an issue with suspend on my HP Pavilion 11 x360.

The screen goes blank but the power LED stays on (if the fan is running it continues to run) and the machine doesn't respond to anything except holding down the power button to power it off.

The same machine has no problems suspending with Ubuntu 17.10 and Kubuntu 17.10 (and also Devuan Jessie, Devuan ASCII and Windows 10).

Using UKUU to install most recent 4.14 kernel fixes this on Kubuntu 18.04.

Trying kernels from 4.15, 4.16 & 4.17 brings the suspend problem back.

Running a Kubuntu 18.04 Live USB has the same suspend problem, suggesting it's not to do with any additional programs I've installed.

I have installed 18.04 on 3 other different machines previously with no suspend problems at all.

An AskUbuntu question -
 - suggests that myself and at least two other people are experiencing this same issue.

It's quite possible others are experiencing this issue but assume that it's just not waking up from suspend - not realising perhaps that it never went to sleep.

kern.log suggests it thinks it has gone to sleep [deep] when it hasn't.

I'd like to report this as a bug, but am not sure how to report what seems to be a kernel 4.15+ bug that only affects a relatively small proportion of users with a particular combination of hardware.

I initially assumed that it was just this particular laptop being a douche, since I didn't find lots of other users reporting this issue as well, but it works fine with 17.10 and Devuan and now I'm using 18.04 with kernel 4.14.47 and suspend behaves properly again.

It doesn't seem to be tied to a particular desktop because the same suspend problem occurred with both Ubuntu and Kubuntu 18.04's.

My concern is that a newcomer to Linux might try out Ubuntu or Kubuntu 18.04 and, if it breaks when they try to suspend their machine, they might just give up or ask on the user forums and get people saying 'What are you talking about? It works fine.' because for most people it's not affecting them.

Where do I report this particular issue?

Are there separate channels each to report bugs for Ubuntu and Kubuntu?
Is there a different reporting procedure for a suspected kernel-related bug?
Is it a bit too much of a leap to think it's a kernel bug because 17.10 behaves fine and downgrading the 18.04 kernel also fixes the issue?

Kindest regards,

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

I suggest you report a bug

Revision history for this message
pHeLiOn (perryhelionsemail) said :

Okay, just reported a general bug - don't know if that's the correct way to go about it - was hoping for some clarification on whether there was a difference between Ubuntu and Kubuntu bugs or whether a suspected kernel bug should be reported differently.

Revision history for this message
pHeLiOn (perryhelionsemail) said :

A 'General Bug' doesn't seem to be what they're after -

"Thank you for taking the time to report this bug and helping to make
Ubuntu better. It seems that your bug report is not filed about a
specific source package though, rather it is just filed against Ubuntu
in general. It is important that bug reports be filed about source
packages so that people interested in the package can find the bugs
about it. You can find some hints about determining what package your
bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage.
You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit
https://bugs.launchpad.net/ubuntu/+bug/1774950/+editstatus and add the
package name in the text box next to the word Package."

So, do you think this should be a kernel bug because it affects Ubuntu 18.04 and Kubuntu 18.04 without seeming to matter which flavour of distro?

(i.e Gnome and KDE both exhibit same behaviour so is it safe to assume that none of the desktop packages are likely to be causing the probem?)

Is suspend-resume considered 'a package' or is it multiple packages that interact?

Just changing the kernel fixes the problem, so would it be safe to say that the kernel is the problem? Is the kernel considered a package?

Revision history for this message
pHeLiOn (perryhelionsemail) said :

I have reported the bug.

One of the devs has adjusted it to fit the correct category.

I am clicking the 'This Solved My Problem' button for actionparsnip, but the answer of 'I suggest you report a bug' wasn't hugely helpful in clarifying what sort of bug I should be trying to report.

I added a lot of detail (perhaps too much) in order to help clarify what the problem was. Perhaps adding too much detail meant that the thrust of the question was lost in amongst it all.

I will try to do better next time.

Revision history for this message
pHeLiOn (perryhelionsemail) said :

Thanks actionparsnip, that solved my question.