Firefox won't load

Asked by Bob Murrell on 2007-05-16

Have been using 7.04 for a few weeks and had good results with firefox until it froze on shutdown earlier today. Rebooted and it won't load. Uninstalled, reinstalled, no joy! Loads and runs from the cd but not the hard drive full install. Any help will be appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Massimo Forti
Solved:
2007-05-16
Last query:
2007-05-16
Last reply:
2007-05-16
Massimo Forti (slackwarelife) said : #1

Thanks for your question. Try to do this command on shell:

$: firefox

post the result you recive. Thanks

Bob Murrell (bmurrell) said : #2

Here is the result, Massimo:

All peers initiated successfully

Segmentation fault (core dumped)

What Next????

Massimo Forti (slackwarelife) said : #3

Try to rename your local .mozilla direcotry with another name (.oldmozilla)
and restart mozilla in a shell with the command before post.

Let me know.

Bob Murrell (bmurrell) said : #4

Do you mean the firefox directory and what is the necessary command?

On 5/16/07, Massimo Forti <email address hidden> wrote:
>
> Your question #6691 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/6691
>
> Status: Open => Answered
>
> Massimo Forti proposed the following answer:
> Try to rename your local .mozilla direcotry with another name
> (.oldmozilla)
> and restart mozilla in a shell with the command before post.
>
> Let me know.
>
> _______________________________________________________________________
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/6691/+confirm?answer_id=2
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/6691
>

Markus Thielmann (thielmann) said : #5

Thanks for your question Bob.

Please use "mv .mozilla/ .mozilla.old/" in terminal. After that, you're able to start firefox with default settings and without additional plugins. If that works, your old profile obviously went defect.

Bob Murrell (bmurrell) said : #6

The message I get is '.mozilla.old/' is not a directory.
where should the .mozilla directory be?

Massimo Forti (slackwarelife) said : #7

The command is:

$: mv .mozilla .oldmozilla

Thanks

Bob Murrell (bmurrell) said : #8

I don't see a mozilla directory on my etc folder. Is that where I should be looking? There is one called mozilla-thunderbird. I still get the message 'No such file or directory'

Massimo Forti (slackwarelife) said : #9

You can do:

$: mkdir .mozilla

after you see if the dir will be create, or post the error you recice.

Thanks

Bob Murrell (bmurrell) said : #10

Now have empty directory /etc/mozilla/ What now??

Best Massimo Forti (slackwarelife) said : #11

Ok. I now understand way you don't see the mozilla dir. You are in /etc, but this dir is not the proble. Now you can delete the /etc/mozilla dir with:

$: rm mozilla

After you can go in /home/your_user_name, to do this you edit this command:

$: cd /home/your_user_name

Now you can see you .mozzila dir and you can do the command:

$: mv .mozilla .oldmozilla

The "." before the dirname is importat because it indicate to the Linux/Unix system the dir you are creating or using is a hiden dir. Thanks

Bob Murrell (bmurrell) said : #12

That worked! Thank you so much, Massimo and others. I would like to have a listing of command-line stuff for ubuntu.

marijal (marijal) said : #13

Hello, my problem is similar. I have two desktops. XP Win is wired connected (ZxXEL modem, LAN) Vista/Ubuntu is wireless connected (wireless EW-7318UG ( WLAN wireless LAN USB adapter).
Vista connection is perfect, everything works, but Ubuntu internet connection is not stabile, the connection goes up and down. Firefox does not connect internet. Same with Epiphany Web browser. Can somebody advice? Many thanks.