cannot move anything to trash from downloads Ubuntu 16.04

Asked by michael on 2018-05-16

I do not if these things are related. Some strange problems with Ubuntu 16.04. Cannot delete anything from downloads, but can from thumbnails. When I downloaded 18.04, had problems. First time torrent downloaded 0 bites. It went through the usual steps. Second time it worked fine, or so I thought. Checked MD5sum, it matched. Took many tries, to burn, used different burners. When I tried to install 18.04, kernel panic, both on try Ubuntu and check disc. (I have never had kernel panic, started in 2008) I ran ClamTK and found two problems. See below. The third thing is I cannot save emails in any way. I do not know if these are related, all started about the same time. If you think they are not related I will make three questions.

https://imgur.com/a/KWQP6qS

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-05-24
Last query:
2018-05-24
Last reply:
2018-05-19

Did you extract the installation ISO?

What is the output of:

ls -la ~/Downloads/dists/bionic/restricted/binary-amd64/Packages.gz

ls -la ~/Downloads/dists/bionic/main/binary-amd64/Packages.gz

michael (yellupcm-gmail) said : #3

Actionparsnip
I did not extract anything.
Answer first output.

 michael@16:~$ ls -la ~/Downloads/dists/bionic/restricted/binary-amd64/Packages.gz
-r--r--r-- 1 michael michael 812 Apr 26 14:43 /home/michael/Downloads/dists/bionic/restricted/binary-amd64/Packages.gz

Second.

michael@16:~$ ls -la ~/Downloads/dists/bionic/main/binary-amd64/Packages.gz
-r--r--r-- 1 michael michael 18570 Apr 26 14:43 /home/michael/Downloads/dists/bionic/main/binary-amd64/Packages.gz

I was going to delete 18.04 and download again. Tried to rename 18.04, it would not let me.

Then why do you have the package files from updates in Downloads?

michael (yellupcm-gmail) said : #5

I do not know. Are you referring to 18.04 or 16.04? 18.04 is on my computer, but will not work. I cannot remove it, or change name, to download again. If 18.04, it came that way. In 16.04 how could that happen? What must I do in 16.04 to correct this? Thanks

Manfred Hampl (m-hampl) said : #6

Files/directories like dists/bionic/main/binary-amd64/Packages.gz inside the Downloads directory do not make any sense. Files like that are supposed to reside on a repository server, but not on your own hard disk. Do you have any idea where they come from?

What is the output of the commands
uname -a
lsb_release -crid
ls -l ~/Downloads

I would like to recommend deleting those file. The access right settings currently do not allow an immediate deletion, but you can change the access rights settings to allow removing the files.

A ossible command for that is
chmod -R u+w ~/Downloads/dists

michael (yellupcm-gmail) said : #8

What do I change to get permissions correct?

https://imgur.com/gw9PbW3

Manfred Hampl (m-hampl) said : #9

The listing shows that you apparently unpacked the installation disk into the Downloads directory, which does not make much sense at all.

For the access rights settings:
Owner File read+write
Owner Folders create+delete
should be correct.

The files/directories from the installation disk are
isolinux
pics
preseed
casper
install
dists
boot
EFI
pool
README.diskdefines
md5sum.txt
They all are quite useless in your Downloads folder and should be deleted.

michael (yellupcm-gmail) said : #10

I think the problem is solved. Will monitor for two days to make sure.
I found an icon marked ubuntu with a symbolic link arrow on it, in downloads. When I clicked on it, it gave me another identical download page. ????? Then I found another icon just like the one above. Clicked on it, another page identical, except no icon of ubuntu with symbolic link arrow. Tried to delete files and folders, and it worked correctly. Cleaned files and folders back to first Downloads. Works as it should. Deleted 18.04 and will download again.

Thank You both for your help!!!

Best Manfred Hampl (m-hampl) said : #11

From your output above:


lrwxrwxrwx 1 michael michael 1 May 12 00:06 ubuntu -> .

There is a link named "ubuntu" in your Downloads folder which points to that folder.
You should consider deleting it as it most probably is not needed.

michael (yellupcm-gmail) said : #12

I deleted both icons, ubuntu with symbolic link arrow. Also the files you listed on #9. It seems to be working correctly now, will do thorough check tomorrow. (5-20-18) I think my age is causing me to forget too many things, like changing permissions. Thank You again.

michael (yellupcm-gmail) said : #13

Thanks Manfred Hampl, that solved my question.