Grub does not work on my system

Asked by Jhessin on 2018-04-15

Hello, I am trying to install ubuntu on a system that came with windows 10 pre-installed. The problem I have is I can't get anything to load from the grub menu. (Neither 'try' nor 'install' options work). The screen simply goes black and stays that way (I let it run all night to see if my system was just being slow with no luck). I even tried manually typing the launch lines and everything works up until I type 'boot' - then nothing. No error - no output - the system just hangs.

Running an ls from the grub command line comes up with some interesting results. It shows some interesting partitions (hd0,apple1) for instance with 'unknown file system' when I try to read it. I don't know if that is related. I would really like to get some type of linux working on this system as windows 10 is such a resource hog, but I have hit a wall any everything I have seen mentioned assumes you can get past the original grub loader (at least to install the system).

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2018-04-19
Last reply:
2018-04-16
Manfred Hampl (m-hampl) said : #1

What make and model is your system, what kind of graphic card does it have?

You might have to add some additional option to the boot lines, maybe "nomodeset".

Which version of Ubuntu are you trying to install?

Jhessin (jhessin) said : #2

I'm sorry I should have mentioned:

It is an HP Pavilian Laptop model: 13-a110dx. It uses Intel HD Graphics 5500 (nothing fancy). I figured there was some type of option I needed to add to the boot lines, but I don't know enough about grub.

Jhessin (jhessin) said : #3

Also I am trying to install the latest ubuntu (I believe it is 17.10.1). I have tried both the lubuntu version as well as the standard desktop ubuntu with the same results.

GRUB is the same between the two. Changing the default desktop environment doesn't alter GRUB

Have you tried the boot option:

nomodeset

It may help

Have you tried Ubuntu 18.04 (Codenamed Bionic) ?

It is LTS and due for release soon. It will be supported until April 2023. Ubuntu 17.10 (Codenamed Artful) is not LTS and only supported until July 2018.

Also try closing the laptop then reopening it
https://youtu.be/cLzAR2ed4EY

Costs nothing to try

Jhessin (jhessin) said : #10

I tried nomodeset (not sure if I'm doing it right). I tried placing 'nomodeset' before the three dashes at the end of the linux cmd line and in place of the dashes. I can't seem to find an exact description of how to 'use nomodeset'.

Did you try:

acpi_osi=Linux acpi_backlight=vendor

too?

Jhessin (jhessin) said : #12

Okay this is what I'm working with. I downloaded the latest Lubuntu version and it is loading GRUB v2.02^beta3-4ubuntu7

When I edit the 'Try Lubuntu without installing' I get this:

```
setparams 'Try Lubuntu without installing'

    set gfxpayload=keep
    linux /casper/vmlinuz.efi file=/cdrom/pressed/lubuntu.seed boot=casper quiet splash ---
    initrd /casper/initrd.lz
```

I imagine it just runs these lines in the loader followed by 'boot'. I have tried the following modifications to the 'linux' line:
```
linux /casper/vmlinuz.efi file=/cdrom/pressed/lubuntu.seed acpi_osi=Linux acpi_backlight=vendor nomodeset boot=casper quiet splash ---
and
linux /casper/vmlinuz.efi file=/cdrom/pressed/lubuntu.seed boot=casper quiet splash nomodeset ---
and
linux /casper/vmlinuz.efi file=/cdrom/pressed/lubuntu.seed boot=casper quiet splash nomodeset
```

As you can probably tell I have no idea what I'm doing here. Are these just like any other command line switches? does it matter the order? Nothing I do seems to change the black screen I get when loading.

Can you help with this problem?

Provide an answer of your own, or ask Jhessin for more information if necessary.

To post a message you must log in.