tp-smapi 0.41 could not load by kernel 4.4.0-116

Asked by stk76 on 2018-03-11

Just wanna give a note: tp-smapi could not load by kernel 4.4.0-116 on Ubuntu 14.04/Linux Mint 17.3, 64bit, MATE on Thinkpad T410, while all 4.4.0-xxx-Kernel did it good BEFORE the 4.4.0-104-Version!
Could it be that all the Meltdown/spectre-Patches and upgrades affect this?
It is a Kernel-bug or a feautures?

Could you give a note to the kernel-developer?

tp-smapi (with tlp) was working all the time great and gives me control about the thinkpad_ec and battery.

Never had problems with this before.
I compiled newest tp-smapi 0.42 with my kernel by myself - but get the same error-message: tp-smapi is there but "inactive" and not loaded by the kernel.

Is there a way to fix this "by hand"?
Or should i wait for next kernel-upgrade?

Thank's for caring!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2018-03-11
Last reply:
2018-03-11

Can you help with this problem?

Provide an answer of your own, or ask stk76 for more information if necessary.

To post a message you must log in.