busy box on boot 16.04LTS

Asked by Ronald on 2018-03-10

It opens with linux mint. When i select ubuntu to boot from it goes to busy box. I would like it boot from Ubuntu. I can type in on busy box.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Ronald
Solved:
2018-03-16
Last query:
2018-03-16
Last reply:
2018-03-15
Ronald (rbski69) said : #1

This extra info. may help.

I have 1 drive 3 SO. 2 Ubuntu and 1 Linux Mint. At boot Linux mint is the first option then the 2 ubuntu systems. In grub if select the first or second Ubuntu systems. It goes to busy box if i select the first or second. Linux Mint is the first one and boots to Linux Mint ok.

Ronald (rbski69) said : #2

Went to advanced options on one of the ubuntu logins. At the end it said neened to do a manual fsck. And it had a status code 4
This extra info. may help also.

Boot to live CD / USB desktop and chroot into the installed OS. You can then troubleshoot your boot. I also suggest you run a full fsck on all Linux partitions to make sure they are all healthy

Ronald (rbski69) said : #4

Do not know what chroot is or how to use it.

Ronald (rbski69) said : #5

I did what it said in question 658199. It work on 1 Ubuntu partition but not on the other. It still goes to busy box.

Manfred Hampl (m-hampl) said : #6

Have you performed a file system check on all Linux partitions?

Ronald (rbski69) said : #7

I run sudo fsck /dev/xxx and now have both Ubuntu systems working. Thank very much Manfred Hampl for your help.You seem to be the one that gets me up and running. Thank you again. Now if i could get Scorched3D to work on my Ubuntu 16.04.4LTS systems i would be a happy camper. But that is another question. Tks. again

Ronald (rbski69) said : #8

Problem solved.

Ronald (rbski69) said : #9

An old question is what helped 3658199

Ronald (rbski69) said : #10

Thanks to actionparsnip also.