16.04 Lost Launcher, Controls after March 5 2018 Update

Asked by Jim Stokes on 2018-03-07

I have lost Unity, although it says it's running when I try to start it via terminal. I have no controls on any of the software I load. All screens are locked to the upper left corner of the screen. I have no way to close them or change their size or shape. No launcher icons. Very frustrating.

Can someone help. I'm not highly skilled or knowledgeable with linux or Ubuntu.

Thanks,
Jim Stokes

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Jim Stokes
Solved:
2018-03-09
Last query:
2018-03-09
Last reply:
2018-03-09
erica hollis (erica-rowancott) said : #1

I have the same problem and also got a query running in Ask ubuntu but despite trying everything suggested there am no further forward. There is also the same problem listed in Ubuntu forums and the user there has resorted to setting up a new user but I despair of ever getting access to my emails and files if I do that.

If you boot an older kernel is it any better?

Jim Stokes (jamesphilipstokes) said : #4

Good question. How would I do that? (I'm not that knowledgeable about linux).

At boot up hold SHIFT
Use cursors to choose the Advanced Settings (or however its worded) then select an older kernel number than the newest (not recovery console though).

It will then boot the older kernel. Is it OK there?

Jim Stokes (jamesphilipstokes) said : #6

Thank you Andrew. I tried booting several times, holding left shift, holding right shift, holding both shift buttons, but never got to anything but the log in screen, as if the shift keys had no effect whatsoever. Maybe this is also part of the problem.

Thanks again for your help.

Jim Stokes (jamesphilipstokes) said : #7

Escape key got me in but there are only three choices, all to version 42. Any more suggestions?

erica hollis (erica-rowancott) said : #8

I did try to do this earlier on but despite getting the option list up by holding shift key, neither arrow keys nor mouse would move the cursor so I could not select anything different and, worse still, the enter key didn't even continue the boot, I had to do a hard shut down holding the power key!

Jim Stokes (jamesphilipstokes) said : #9

Can anyone help with this?

I installed ubuntu-generic (version 144) and tried booting from that, but still had no luck in getting controls back. Still missing unity, all the control icons, everything but ability to use a terminal.

Perhaps reloading a previous version? How to do this? Apparently I've only got versions 42 or 144 available at GNU.

When I try to start Unity, it says it is running and gives me process number, etc. But I can't get to anything that would normally be shown on the perifery of my screen.

Please help if you can.

Thanks, Jim Stokes

I started unity-control-center and got the following messages (which may help somebody help me with this problem?):

jimstokes@jimstokes-HP-Pavilion-15-Notebook-PC:~$ unity-control-center

(unity-control-center:3248): unity-control-center-WARNING **: Could not load /usr/share/themes/Adwaita/index.theme: No such file or directory

(unity-control-center:3248): Gtk-CRITICAL **: gtk_notebook_set_current_page: assertion 'GTK_IS_NOTEBOOK (notebook)' failed

(gkbd-keyboard-display:3402): Gtk-CRITICAL **: gtk_widget_set_allocation: assertion '_gtk_widget_get_visible (widget) || _gtk_widget_is_toplevel (widget)' failed
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
/usr/bin/update-manager:28: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
/usr/lib/python3/dist-packages/UpdateManager/UnitySupport.py:29: PyGIWarning: Dbusmenu was imported without specifying a version first. Use gi.require_version('Dbusmenu', '0.4') before import to ensure that the right version gets loaded.
  from gi.repository import Dbusmenu, Unity
/usr/lib/python3/dist-packages/UpdateManager/UnitySupport.py:29: PyGIWarning: Unity was imported without specifying a version first. Use gi.require_version('Unity', '7.0') before import to ensure that the right version gets loaded.
  from gi.repository import Dbusmenu, Unity
debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied
debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied
debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied
^C
jimstokes@jimstokes-HP-Pavilion-15-Notebook-PC:~$

Arjan Prins (prinsarjan) said : #11

Hi Jim,

I had the same problem and I don't know if it's THE solution but this was my solution. I simply upgraded to a new version of Ubuntu.
I had 16.04 LTS and now 17.10.

With the right mouse button you can still go to the configuration screen via "change desktop background" go back to the main screen and then go to "upgrades" then change the configuration "search for new version" in the tab "upgrades" from never to always.

This way Ubuntu will look for new versions and will guide you through to the installation you now have a new version and that flawed upgrade is gone.

Hope you can make something out of this and your problem solved.

hummingbird (hummingbird) said : #12

I starting having very similar problems after a software update on March 6. It was supposed to download 6 updates and it did 9. When I restarted the computer, there was NO Navigation bar. Everything opened has no way to close it down, and I have to use the power button to shut down the computer--no bar at the top to shut down.

Caesarivs (caesarivs) said : #13

Please try to remove .cache directory on home:

rm -r ~/.cache

THANK YOU CAESARIVS. IT WORKED!!!! FANTASTIC!!! AMAZING!!!

And I was just about to reload 16.04, (which didn't give me an option to reload, just lose data).

One glitch: with your command, I got a protected directory error. Instead I used:

sudo -r ~/.cache

AND IT WORKED!!!!

Thank you so much. Have a great weekend (and life).

Thanks, Jim.

Thank you very much Caesarivs & Jim - mine now sorted too. Wonderful after two days of struggle.

If possible, Caesarivs?

Could you give a little explanation about why this was the problem? I'd like to understand what was causing it.

Thanks.
Jim.

Caesarivs (caesarivs) said : #17

I'm glad it worked for you guys, I actually don't know what was causing the problem and why deletting that directory would solve it, I just tried creating a new user account to see if it was user related or if it was system wide, and since it worked I tried to figure out which dot files would be convenient to delete and see if it worked, the first one was .cache directory since the name sounded like it wasn't important and should be recreated when using the system, and it worked! :D