Problem with external monitor screen resolution after BIOS update DELL inspire e7240

Asked by Olle Kjellqvist on 2018-03-07


I updated the bios to the latest BIOS for my Dell e7240 laptop, running Ubuntu 17.10.
I'm using a dock to connect an external monitor to my system, using a VGA cable.
Before running the BIOS update I had access to several screen resolutions, including my preferred 1920x1080.
After running the BIOS update many of the available modes dissapeared, including my preferred mode.

Steps taken:

Downgraded BIOS - no difference.
Tried to add modes using xrandr - I use Wayland, so does not work.
Tried to run Ubuntu on instead so I could use xrandr-
    Can't log onto see separate question:

Any help is really appreciated.

/ O

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Olle Kjellqvist
Last query:
Last reply:

What is the output of:

sudo lshw -C display; xrandr


Olle Kjellqvist (oxac) said : #2

       description: VGA compatible controller
       product: Haswell-ULT Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 0b
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:45 memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64) memory:c0000-dffff
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
XWAYLAND1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768 59.92*+

Olle Kjellqvist (oxac) said : #4

None of these steps worked, I got pissed off and reinstalled the entire OS (changed to Mint while I was at it). That solved the problem.