Serial port /dev/ttyS0 not working on ubuntu (LSR safety check engaged)

Asked by Hari Prasad V on 2018-03-05

Serial port(COM0 and COM1) are working in windows, but not on ubuntu (14.04)
$ dmesg | grep tty
gives LSR safety check engaged for /dev/ttyS0
I have also verified that i have permission to read/write the port, and that i am a part of the dialout group.
$ setserial -g /dev/ttyS0
It has UART: 16550A, and it is not unknown/undefined.

NOTE: The serial ports on another identical motherboard are working fine with this hardisk (ubuntu 14.04). The problem is only with the former motherboard, that too only on ubuntu (works fine on windows).

Been stuck on this for many days. Any help will be really appreciated.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2018-03-06
Last reply:
2018-03-23

What is the output of:

ls -la /dev/ttyS0; lsb_release -a; uname -a

Thanks

Hari Prasad V (hariprasadv) said : #2

$ ls -la /dev/ttyS0; lsb_release -a; uname -a; id;

crw-rw-rw- 1 root dialout 4, 64 Mar 7 01:54 /dev/ttyS0
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.3 LTS
Release: 14.04
Codename: trusty
Linux matsya-desktop 3.16.0-60-generic #80~14.04.1-Ubuntu SMP Wed Jan 20 13:37:48 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
uid=1001(auv) gid=1001(auv) groups=1001(auv),4(adm),20(dialout),27(sudo),108(lpadmin),119(nopasswdlogin),124(sambashare)

Seems you are in the right groups etc. If you run your application as root, does it work OK?

Hari Prasad V (hariprasadv) said : #5

Tried reading/writing on cutecom(opened with $sudo cutecom), but it still does not work

Launchpad Janitor (janitor) said : #6

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.

Hari Prasad V (hariprasadv) said : #7

a BIOS update from the manufacturer, solved the serial port issue, and now I am able to read and write, on both Ubuntu 14.04 and Ubuntu 16.04