wifi -> broadcom -> update to 4.4.0-116 mismatch wl mod

Asked by eric m on 2018-02-22

Hello, I have update today my ubuntu 16 distrib.
here is my kernel : 4.4.0-116-generic #140-Ubuntu
Since on network manager i lost wifi profile.

I have these result with wl
sudo modprobe wl
modprobe: ERROR: could not insert 'wl': Exec format error

dmesg | grep wl
[ 3.301189] wl: version magic '4.4.0-116-generic SMP mod_unload modversions ' should be '4.4.0-116-generic SMP mod_unload modversions retpoline '
[ 204.995529] wl: version magic '4.4.0-116-generic SMP mod_unload modversions ' should be '4.4.0-116-generic SMP mod_unload modversions retpoline '
[ 240.830345] wl: version magic '4.4.0-116-generic SMP mod_unload modversions ' should be '4.4.0-116-generic SMP mod_unload modversions retpoline '

sudo apt-get --reinstall install bcmwl-kernel-source
...
...
...
Removing all DKMS Modules
Done.
Dépaquetage de bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.2) sur (6.30.223.271+bdcom-0ubuntu1~1.2) ...
Paramétrage de bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.2) ...
Loading new bcmwl-6.30.223.271+bdcom DKMS files...
Building only for 4.4.0-116-generic
Building for architecture x86_64
Building initial module for 4.4.0-116-generic
Done.

wl:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.4.0-116-generic/updates/dkms/

depmod....

DKMS: install completed.
modprobe: ERROR: could not insert 'wl': Exec format error
update-initramfs: deferring update (trigger activated)
Traitement des actions différées (« triggers ») pour initramfs-tools (0.122ubuntu8.10) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-116-generic

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2018-02-22
Last reply:
2018-02-25
gumbeto (gumbeto) said : #1

A workaround for the moment is to load the previous kernel (4.4.0-116) in grub.

gumbeto (gumbeto) said : #2

(I meant 4.4.0-112 as the previous kernel)

Manfred Hampl (m-hampl) said : #3

Look similar to Bug #1750937

Proposals for help from that bug (not verified / tested by me):
Either dkms remove /dkms install
or
completely uninstall the -116 kernel packages and install them again

Can you help with this problem?

Provide an answer of your own, or ask eric m for more information if necessary.

To post a message you must log in.