Thunderbird does not connect with Email provider

Asked by srikumar

using Ubuntu 17.10
Thunderbird 52.6.0 (64 bit) with latest upgrades

About a week ago Thunderbird stopped receiving and sending Emails. Until then it worked fine. Was there some upgrade that caused this problem.
The ISP states that their end is OK and suggests that Thunderbird be removed and re-installed. Should I do this.

I am able to send and receive emails through the internet connection but would prefer to use Thunderbird.

Any suggestions?

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
srikumar
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Uninstalling and reinstalling the application probably won't do anything.

What protocol are you connecting to your email provider with?
Who is your email provider?
Does the system have internet access OK?
Can you ping the email servers OK?

Revision history for this message
srikumar (ssrikumar) said :
#2

hope this is the info you require:-

POP Mail server
Server Name : sltnet.lk Port 110 Default 110

Outgoing Server:
SMTP Server
Server Name: auth.slt.lk Port 25 Default 587 (the ISP says that 25 is the correct port, but tried 587 no luck)

email provider : sltnet.lk (Sri Lanka Telecom)

Internet access is OK. Can access the email using webmail and can send and receive emails. However cannot do this with Thunderbird now although this could be done earlier.

user@user-System-Product-Name:~$ ping sltnet.lk
PING sltnet.lk (203.115.0.191) 56(84) bytes of data.

Please instruct if any other info is required.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#3

Can you Telnet (in the terminal) to the port numbers on the mail server addresses?

Revision history for this message
srikumar (ssrikumar) said :
#4

user@user-System-Product-Name:~$ telnet sltnet.lk 110
Trying 203.115.0.191...
Connected to sltnet.lk.
Escape character is '^]'.
+OK SLTNet POPPER

user@user-System-Product-Name:~$ telnet sltnet.lk 25
Trying 203.115.0.191...
(no further response)

user@user-System-Product-Name:~$ telnet sltnet.lk 587
Trying 203.115.0.191...
 (no further response)

aslo tried
user@user-System-Product-Name:~$ ping 203.115.0.191
PING 203.115.0.191 (203.115.0.191) 56(84) bytes of data.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#5

Looks like your provider has changed ports. Check their website for correct settings or check any firewall and proxies (if you use one) are allowing the traffic

Revision history for this message
Manfred Hampl (m-hampl) said :
#6

Please look at the information that you have provided:

In response #2 you write:
"...Server Name: auth.slt.lk Port 25..."

And in response #4 you try
"...telnet sltnet.lk 25..."

You are trying the wrong server address!

Revision history for this message
srikumar (ssrikumar) said :
#7

Thank you, hope this is Ok.

user@user-System-Product-Name:~$ telnet auth.slt.lk 25
Trying 203.115.0.189...
Connected to auth.slt.lk.
Escape character is '^]'.
220 ovw1.sltnet.lk ESMTP Postfix

Revision history for this message
Manfred Hampl (m-hampl) said :
#8

This shows that a connection is possible.
Thunderbird does nothing different, if it is correctly configured.

I suggest that you re-check the connection information that you have received from your e-mail provider and correctly put it into the thunderbird settings dialogue.

I recommend that you read and follow the instructions in the links that I posted to your other question about thunderbird.

Revision history for this message
srikumar (ssrikumar) said :
#9

Thank you. Thunderbird did work well until about a week ago, after which the non-connection problem started. Perhaps there was an upgrade that upset the earlier settings.

Have contacted SLT and went through all the settings one by one but some things are different and cannot be changed.
SLT says POP3 for the incoming server but Thunderbird has chosen POP Mail Server and this cannot be changed.
SLT says "Password Normal" but the closest Thunderbird choice is "Password, transmitted insecurely" for both the incoming server and the outgoing SMPT Server. Perhaps the wordings are different.

Will read through the link once again and try.

Revision history for this message
srikumar (ssrikumar) said :
#10

have completely removed Thunderbird usaing the purge command and also deleted the hidden .\thunderbird directory
and the re-installed Thunderbird.
Now it works as usual.

Thank you.