16.04 will not accept password, guest works fine

Asked by michael on 2018-01-10

Ubuntu 16.04 started asking for password. It was set not to. It would not accept it, just ask again, and again. Tried guest, asked for password, accepted it. I went through site recommended (can't remember name) and reset password. Still does not work. Gone through BIOS, recover and anything else I could think of, still does not work. Guest does not require password after first time. The desk top picture that I put on the screen does not show. Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-01-19
Last query:
2018-01-19
Last reply:
2018-01-12
michael (yellupcm-gmail) said : #1

http://www.psychocats.net/ubuntu/resetpassword

Is site I used. At finish it said I had new password.

OK and when you log in to the system as your user, does the new password work?

Bios password is nothing to do with Ubuntu

michael (yellupcm-gmail) said : #4

Actionparsnip
No, nothing changed. Same as before, I put in new password, a screen comes up with text, for less than a second, then black screen also less than a second. Then to login screen again. Guest works, as before, just click on login. I do not use guest often, but I do not ever remember it needing a password. Sometimes the refresh rate is wrong. So bad I cannot use it, must reboot. There was what I think may be error message. Will post, and give site its on. Getting late here, be back tomorrow. Thanks for answering.
.

Manfred Hampl (m-hampl) said : #5

This seems not to be a problem with the password, but some kind of crash that logs you off again immediately after logging in.

When did this problem start? After a recent package update?

Can you log in on a virtual terminal (e.g. ctrl-alt-F2)?

michael (yellupcm-gmail) said : #6

Manfred
Yes. I get logged in, there are 22 lines of information. Then ( michael@16:/$ ) and blinking _ after $ sign. Would send picture, but neither Pastebin or Imgur will accept my photos.
In the 22 lines of information, do not know what this means.
           No directory, logging in with HOME=/
           To run command as administrator (user "root"), use "sudo <command>".
           See "man sudo_root" for details.
Problem started two days ago. Three days ago I ran a diagnostics program, from Ubuntu Software Center. Can't remember the name. Only thing I noticed, after program completed, computer would not read USB stick, that I had inserted at request of program. Reads OK on laptop I am using now. After shutdown that day, have not been able to get in. Don't remember an update. Had forgotten this, just remembered, or would mentioned sooner. When I can get some program working, I will send site for pictures. Thanks for answering.

Manfred Hampl (m-hampl) said : #7

Maybe this is the important hint:
"No directory, logging in with HOME=/"

It seems that something is wrong with your home directory.
If you log on in a virtual terminal and issue the command

ls -l /home

what output do you get?

By the way, to shut down the computer from that mode you can use the command
sudo shutdown now

michael (yellupcm-gmail) said : #8

michael@16:/$ ls -l /home
total 16
drwx------ 2 root root 16384 Aug 6 2016 lost+found

I believe you are right about password. Any time I put incorrect password in, it tells me it is wrong.

Manfred Hampl (m-hampl) said : #9

Your home directory got lost.

Did you set up a separate partition for home?

What is the output of

df -h | grep '/dev'

(the important information is in the first and last columns, you can ignore the numbers in the size columns)?

michael (yellupcm-gmail) said : #10

guest-gwznbq@16:~$ df -h | grep '/dev'
udev 1.9G 0 1.9G 0% /dev
/dev/sdb1 38G 30G 6.3G 83% /
tmpfs 1.9G 20M 1.9G 1% /dev/shm
/dev/sdb3 45G 52M 43G 1% /home
guest-gwznbq@16:~$

Is this ok, or do I need to do it like #8? --------michael@16:/$

I think you have found the problem. I made a mistake in partitioning, when I originally installed 16.04. Made three partitions. First ( sdb1 ) was set as " / " and flag boot. Second ( sdb3 ) was larger. I usually set as " /home ", but some how didn't. Then made swap partition. Some time ago, went to Gparted, and added " /home " to second partition ( sdb3 ). Do you think if I remove " /home " from second partition ( sdb3 ), it should work correctly? Then enlarge first partition to combine sbd1 and sbd3.

Best Manfred Hampl (m-hampl) said : #11

Good idea to log in as guest to allow copy/paste.

If your problem is caused by the fact that the /dev/sdb3 partition now hides the /home directory from /dev/sdb1, then I see several possibilities:

1. Keep the separate /home partition and copy all data from the /home part of the root partition to the /dev/sdb3 partition. There is guidance for this in https://help.ubuntu.com/community/Partitioning/Home/Moving

2. (already mentioned by you): remove the /dev/sdb3 partition (and all references to it, e.g. in /etc/fstab) and go back to having /home as part of the root partition. Eventually enlarge the root partition.

I suggest that you perform some test before starting:
Log in to a virtual terminal and issue the commands

sudo umount /dev/sdb3
ls -l /home
ls -la /home/michael

Do you see your files and directories?

michael (yellupcm-gmail) said : #12

Manfred
Solved!! Your #9 was the answer. The commands above, bottom #11, never worked as I though they should. Studied the site you gave in #11, bit to completed for my old brain. Did the # 2 in your last post, works just fine. I would have never found the problem myself. Thanks a lot.

michael (yellupcm-gmail) said : #13

Thanks Manfred Hampl, that solved my question.