Package from wrong repository

Asked by Bruce Miller on 2018-01-05

This question asks for help determining the cause of a problem on my Ubuntu 17.10 installation for the last several weeks. I would also appreciate help on what I should do to prevent it happening again.

A package from artful-proposed has come into my dpkg tree. I filed bug 1737318. A developer quickly marked it as invalid, and "accused" me of:
1) installing packages individually rather than together;
2) of permitting my system to download artful-proposed packages.

Neither allegation is true. I was not amused. I do *_not_* install packages individually. I do not have any reference to artful-proposed anywhere on my system, and least of all, in /etc/apt/sources.list.

The developer was right identifying the problem package. He was wrong in guessing how it found its way into my system.

bruce@CatoMinor:~$ apt-cache policy systemd
systemd:
  Installed: 234-2ubuntu12.1
  Candidate: 234-2ubuntu12.2
  Version table:
     234-2ubuntu12.2 500
        500 http://archive.ubuntu.com/ubuntu artful-proposed/main amd64 Packages
 *** 234-2ubuntu12.1 500
        500 http://ca.archive.ubuntu.com/ubuntu artful-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu artful-security/main amd64 Packages
        100 /var/lib/dpkg/status
     234-2ubuntu12 500
        500 http://ca.archive.ubuntu.com/ubuntu artful/main amd64 Packages
bruce@CatoMinor:~$

The report I am getting when I run a full-upgrade or a dist-upgrade is:

Current status: 3 (-2) upgradable.
The following packages will be upgraded:
  libpam-systemd libsystemd0 systemd
3 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/3,099 kB of archives. After unpacking 2,048 B will be used.
The following packages have unmet dependencies:
 libnss-resolve : Depends: systemd (= 234-2ubuntu12.1) but 234-2ubuntu12.2 is to be installed
open: 29; closed: 945; defer: 6; conflict: 6 .The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1) libpam-systemd [234-2ubuntu12.1 (artful-security, artful-updates, now)]
2) libsystemd0 [234-2ubuntu12.1 (artful-security, artful-updates, now)]
3) systemd [234-2ubuntu12.1 (artful-security, artful-updates, now)]

These bring me back to my original questions:
1: What has happened?
2. How do I resolve the immediate problem?
3. What do I do to prevent a recurrence?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2018-01-05
Last reply:
2018-01-05
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes please provide the output of the commands

grep proposed /etc/apt/sources.list /etc/apt/sources.list.d/*.list
apt-cache policy libnss-resolve

Bruce Miller (brm0423) said : #2

Thanks for the question. It answers one question --- but raises another.

bruce@CatoMinor:~$ grep proposed /etc/apt/sources.list /etc/apt/sources.list.d/*.list
/etc/apt/sources.list.d/proposed.list:deb http://archive.ubuntu.com/ubuntu/ artful-proposed main restricted
bruce@CatoMinor:~$ apt-cache policy libnss-resolve
libnss-resolve:
  Installed: 234-2ubuntu12.1
  Candidate: 234-2ubuntu12.1
  Version table:
 *** 234-2ubuntu12.1 500
        500 http://ca.archive.ubuntu.com/ubuntu artful-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu artful-security/universe amd64 Packages
        100 /var/lib/dpkg/status
     234-2ubuntu12 500
        500 http://ca.archive.ubuntu.com/ubuntu artful/universe amd64 Packages
bruce@CatoMinor:~$

So, now I see where the proposed package came from.

But the question remains: how did this file in /etc/apt/sources.list.d/ get written? It was not by my hand.

I upgraded from 17.04 to 17.10 "in place." That is, with the command "sudo do-release-upgrade -d" or its graphical equivalent. I no longer remember with certainty how I upgraded from 16.04 LTS to 17.04. My recall is that I did a "reformat / and install."

(BTW, I have had /home on a separate petition since I began using Linux in the early 2000s. Since retiring, I have ceased to follow Linux technical development, and use it simply as my daily environment.)

My current working hypothesis is that the Ubuntu upgrade process incorrectly added a "proposed" file to /etc/apt/sources.list.d. Can I test this without doing a whole new "reformat / and install."

Manfred Hampl (m-hampl) said : #3

The upgrade process will not add "releasename-proposed" repository entries to the sources.list file (and also not in to the sources.list.d directory) unless it was already there in the previous release.

What are the full contents of the file?
What is the creation date of that file?
Maybe this can help finding out when the -proposed repository was enabled?

Bruce Miller (brm0423) said : #4

It is possible that I upgraded to 17.04 about nine months ago during an RC stage, that is, before official release.

bruce@CatoMinor:/etc/apt/sources.list.d$ ls -l proposed*
-rw-r--r-- 1 root root 70 Oct 23 10:37 proposed.list
-rw-r--r-- 1 root root 69 Oct 23 10:37 proposed.list.distUpgrade
-rw-r--r-- 1 root root 69 Jun 15 2017 proposed.list.save

bruce@CatoMinor:/etc/apt/sources.list.d$ cat proposed.list
deb http://archive.ubuntu.com/ubuntu/ artful-proposed main restricted
bruce@CatoMinor:/etc/apt/sources.list.d$ cat proposed.list.distUpgrade
deb http://archive.ubuntu.com/ubuntu/ zesty-proposed main restricted
bruce@CatoMinor:/etc/apt/sources.list.d$ cat proposed.list.save
deb http://archive.ubuntu.com/ubuntu/ zesty-proposed main restricted
bruce@CatoMinor:/etc/apt/sources.list.d$

Manfred Hampl (m-hampl) said : #5

The modification date on proposed.list.save shows that this file existed already in June 2017 and at that time had proposed for zesty (Ubuntu 17.04) enabled.
During release-upgrade from 17.04 to 17.10 on October 23, 2017 it was updated to reflect the change from zesty to artful.

That is all I can say.

I recommend that you disable that repository now, and then the installation of libnss-resolve (or whatever you tried to install) should work.
You have to be aware that you might run into dependency problems whenever you install packages, if there are dependencies between packages that are already installed from proposed and other not-yet-installed packages.

Can you help with this problem?

Provide an answer of your own, or ask Bruce Miller for more information if necessary.

To post a message you must log in.