streaming on web browser ubuntu 16.04

Asked by Henry Folorunsho on 2017-12-03

Hello,

please kindly assist me. am running ubuntu 16.04, i once stream on VIPBOX TV, But try to stream now with no luck. saying adobe flash is outdated. i done an update and re-install adobe flash player with no luck please assist me

henry

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2017-12-04
Last reply:
2017-12-19

What browser(s) have you tried?

What is the output of:

lsb_release -a; uname -a; dpkg -l | egrep -i flash|gnash|swf|spark

Thanks

Henry Folorunsho (henryxav) said : #2

i tried firefox and chromium

here is the output

henry@polaris:~$ lsb_release -a; uname -a; dpkg -l | egrep -i flash|gnash|swf|spark
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial
Linux polaris 4.4.0-101-generic #124-Ubuntu SMP Fri Nov 10 18:29:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
Could not find any <gui>-gnash executable under directory /usr/bin, with <gui> in .
No command 'swf' found, did you mean:
 Command 'sdf' from package 'sdf' (universe)
 Command 'sf' from package 'ruby-sprite-factory' (universe)
 Command 'syf' from package 'alliance' (universe)
 Command 'swfc' from package 'swftools' (universe)
swf: command not found
           *******************************************************
                              Examiner GPL 2012
             Copyright (C) 2012 Altran Praxis Limited, Bath, U.K.
           *******************************************************

                        DATE : 03-DEC-2017 11:53:57.90

Usage: spark {options} Argument-list
Argument-list = Argument {" " Argument }
Argument = ( File-spec [Argument-option] ) | Meta-file-spec
Argument-option = ( "-listing_file=" file-spec | "-nolisting_file" )
Meta-file-spec = "@"file-spec

Options - all may be abbreviated to the shortest unique prefix

Input File Options
-source_extension=file-type - specifies source file extension (Default .ada)
-index_file=file-spec - specifies index file
-noindex_file - suppress index file (Default)
-warning_file=file-spec - specifies warning control file
-nowarning_file - all warnings reported (Default)
-target_compiler_data=file-spec - specifies target compiler data
                                  This option is now deprecated by -config_file
-notarget_compiler_data - suppress target compiler data (Default)
-config_file=file-spec - specifies Examiner configuration file
-noconfig_file - suppress configuration file (Default)
-noswitch - ignore spark.sw file

Output File Options
-listing_extension=file-type - specifies listing file extension (Default .lst)
-report_file=file-spec - specifies report file name (default SPARK.REP)
-noreport_file - suppress report file
-html[=dir_spec] - Generate HTML listings and report file
-output_directory=dir_spec - Generate report, listing, and proof files
                               in specified directory
                               Default is in and below current working directory
-nolistings - suppress all listing files
-plain_output - No dates, line, or error numbers in output files

Language and Analysis Options
-language=choice - select 83, 95, or 2005 language rules.
                      Default is 95
-profile=language - select sequential or ravenscar language profile.
                      Default is sequential
-noduration - do not predefine Standard.Duration
-syntax_check - syntax check only. No semantic checks
-flow_analysis=type - select "information"-, "data"- or "auto"-flow analysis
                      Default is "information"
-policy=type - select "security" or "safety" policy for flow analysis
-vcg - Generate VCs
-dpc - Generate DPCs
-rules=type - Select policy for generation of composite constant proof rules
              - valid values: none, lazy, keen, all
              - default: lazy

Debugging and Tracing Options
-debug[=choices] - choices is a sequence of letters, where:
                             c - trace component manager state
                             d - print FDL DAG after BuildExpnDAG
                             e - trace expression walking
                             f - trace file handling
                             h - trace HTML generation
                             i - print default loop invariants in FDL
                             k - trace ranking and printing of FDL declarations
                             l - trace entity lookup in dictionary
                             p - print parser state on syntax error
                             r - print required and computed flow relations
                                 for each subprogram
                             t - print extra information when -statistics is on
                             u - trace required unit and index file lookups
                             v - print VCG State and BPG after DAG.BuildGraph
                             V - as v, but also print BPG during each iteration
                                 of VC generation
                             x - print cross-reference
-dictionary_file=file-spec - dump Dictionary into given file

Other Options
-annotation_character=char - select alternate annotation character (Default #)
-noecho - suppress screen output
-nosli - don't generate SLI files
-sparklib - use the standard SPARK library
-statistics - append Examiner table usage statistics to report file
-nostatistics - no statistics reported (Default)
-fdl_identifiers=option - Control treatment of FDL identifiers
                          settings are "reject" (Default),
                                       "accept" or
                                       "<string>"
-version - print Examiner banner, statistics, then exit
-brief[=choices] - errors and warnings in brief (gcc-style) format, where:
                     nopath - omit path (Default)
                     fullpath - report full path
-makefile - only absolutely essential output, useful when using
                     the Examiner in a makefile (requires -brief)
-help - print command line summary and options
-original_flow_errors - print information flow errors in original,
                            less compact, format
-error_explanations=setting - print explanations after error messages
                              settings are "off", "first_occurrence"
                                                 or "every_occurrence"
                              default is "off"
-justification_option=type - select policy for justification of errors
                           - values: full, brief, ignore
                           - default: full
-casing[=choices] - check casing for identifier references and
                check casing of package Standard identifiers
              - s - check casing of package Standard identifiers
              - i - check casing for identifier references

Report bugs to: <email address hidden>

Sorry forgot the quotes.

dpkg -l | egrep -i 'flash|gnash|swf|spark'

What is the output please?

Henry Folorunsho (henryxav) said : #4

henry@polaris:~$ dpkg -l | egrep -i 'flash|gnash|swf|spark'
rc adobe-flashplugin 1:20171114.1-0ubuntu0.16.04.1 amd64 Adobe Flash Player plugin
ii browser-plugin-freshplayer-pepperflash 0.3.6-1~webupd8~xenial6 amd64 PPAPI-host NPAPI-plugin adapter for pepperflash
ii flashplugin-installer 27.0.0.187ubuntu0.16.04.1 amd64 Adobe Flash Player plugin installer
ii gnash-common 0.8.11~git20160109-1build1 amd64 GNU Shockwave Flash (SWF) player - Common files/libraries
ii libhal1-flash 0.3.3~xenial1.0 amd64 Compatibility library to allow playback of Flash DRM content
ii pepperflashplugin-nonfree 1.8.2ubuntu1.1 amd64 Pepper Flash Player - browser plugin
ii spark 2012.0.deb-11 amd64 SPARK programming language toolset

Henry Folorunsho (henryxav) said : #5

i install gnash and spark

Its working on Firefox now, but still wont work on chromium.

I suggest you remove all flash packages:

sudo dpkg -P adobe-flashplugin
sudo apt-get --purge remove browser-plugin-freshplayer-pepperflash
sudo apt-get --purge remove flashplugin-installer
sudo apt-get --purge remove gnash pepperflashplugin-nonfree
sudo apt-get --purge autoremove
sudo apt-get clean

Close all browsers or reboot then run:

sudo apt-get install adobe-flashplugin pepperflashplugin-nonfree

Should do it. If you use Chrome then it'll probably be OK.

Henry Folorunsho (henryxav) said : #8

thanks is working but not properly it drags and moves slowly

Launchpad Janitor (janitor) said : #9

This question was expired because it remained in the 'Open' state without activity for the last 15 days.