Monitor resolution stuck to 1024x768 at HP G4 250 notebook

Asked by Orion's Belt on 2017-12-02

Hi,

I have a HP G4 250 notebook that I installed Ubuntu 17.04 and updated+upgraded all packs.

It did not recognize and install a display adapter for HP G4 250 notebook and I am stuck to 1024 x 768 on my 24" monitor.

Please help me solve this problem.

Thank you very much

Orionsbelt

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Orion's Belt
Solved:
2017-12-02
Last query:
2017-12-02
Last reply:
2017-12-02

What is the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks

Orion's Belt (orionsbelt) said : #2

Hi Actionparsnip,

Thanks... It says :

-----------------------------

sudo lshw -C display; lsb_release -a; uname -a
  *-display
       description: VGA compatible controller
       product: Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 21
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:118 memory:90000000-90ffffff memory:80000000-8fffffff ioport:2000(size=64) memory:c0000-dffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 17.04
Release: 17.04
Codename: zesty
Linux uubuntu 4.10.0-40-generic #44-Ubuntu SMP Thu Nov 9 14:48:37 UTC 2017 i686 i686 i686 GNU/Linux

-----------------------------

I guess it is i915 --> "Intel HD Graphics". I found out the Intel software that I should install and did it :
"intel-graphics-update-tool_2.0.5_i386.deb"

But the installation does not end properly giving an error about "NO SIGNATURE" or something.

With these I cannot do something.

Please help, thanks.

Can you give the output of:

sudo dpkg -i ~/Downloads/intel-graphics-update-tool_2.0.5_i386.deb

Thanks

Orion's Belt (orionsbelt) said : #4

Sure, here what it says :

sudo dpkg -i ~/Downloads/intel-graphics-update-tool_2.0.5_i386.deb
dpkg: error: cannot access archive '/root/Downloads/intel-graphics-update-tool_2.0.5_i386.deb': No such file or directory

By the way, I had manually downloaded 2.0.5 from Intel's website. The .deb file is on my desktop. I can right click and install it but when I run it cannot complete its actions.

It even messed my apt-get update / upgrade results and I cannot even complete them any more.

Are you logging in to the system as root?

Just change the path to the deb file, you can easily change the folder name

Orion's Belt (orionsbelt) said : #6

I typed your messages as root

But I ran the software over the desktop of my Ubuntu X user which is an administrator but not root.

I tried to run the .deb it over Console:

Checking if Intel graphics card available...
  • checking for i915 module in /sys/module
  • i915 module found
Checking if Intel graphics card available... OK
Retrieving information from 01.org...
  • fetching https://download.01.org/gfx/ilg-config.cfg
  • saving to /home/unal/.ilg-config
  • fetched 1626 bytes
  • fetched 9818 bytes
  • fetched 12301 bytes
  • looking up [Ubuntu zesty] configuration
Retrieving information from 01.org... OK
Checking distribution... OK
Checking kernel version... OK
Checking available repositories... OK
Checking package manager status... OK

WHEN I PRESS INSTALL :

Ensuring consistent system... OK
Listing packages... OK
Setting up repositories... OK
Installing packages...
 Updating package cache...

THEN IT GIVES AN ERROR LIKE THIS (I have typed the message, coz it cannot be copied-pasted) :

W:GPG error:https://download.01.org/gfx/ubuntu/17.04/main zesty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 611B903CAB97EA77, E:The repository 'http://download.01.org/gfx/ubuntu/17.04/main zesty InRelease' is not signed.

Orion's Belt (orionsbelt) said : #7

I could install the DEB using :

sudo dpkg -i /root/intel-graphics-update-tool_2.0.5_i386.deb

after copying the DEB file to root.

Then I ran the Intel application from X. I still get the same error as I wrote above.

There is still 1024x768 as resolution

So ?

Orion's Belt (orionsbelt) said : #8

SOLVED : I have solved the issue MYSELF focusing on "UNKNOWN MONITOR" issue here.

I knew the 3 resolutions below had been perfectly working on the same computer over Windows 10 ( also installed ). So I added them to my list.

See the resolutions and the connected interface name over :

xrandr -q

Then I added these resolutions to be available in the list.

xrandr --newmode $(cvt 1280 1024 60 | grep Mode | sed -e 's/.*"/1280x1024/')
xrandr --newmode $(cvt 1600 1200 60 | grep Mode | sed -e 's/.*"/1600x1200/')
xrandr --newmode $(cvt 1920 1080 60 | grep Mode | sed -e 's/.*"/1920x1080/')

Then I added them to the interface that I am using -- mine was DP2 , your might be VGA, DVI, HDMI, etc...

xrandr --addmode DP2 1280x1024
xrandr --addmode DP2 1600x1200
xrandr --addmode DP2 1920x1080

Then, Voila ! It works...

And, NO need to REBOOT !!!

Note: Please make sure you add WORKING or WORKABLE resolutions to the list !