dpkg error I can't fix

Asked by mark ricketts on 2017-11-13

I'm attempting to install the latest kernel in this example but it doesn't matter what I try to install....same thing happens.

msdr@odbo:~/Downloads/linuz$ ls
linux-headers-4.14.0-041400_4.14.0-041400.201711122031_all.deb linux-image-4.14.0-041400-generic_4.14.0-041400.201711122031_amd64.deb
linux-headers-4.14.0-041400-generic_4.14.0-041400.201711122031_amd64.deb
msdr@odbo:~/Downloads/linuz$ sudo dpkg -i *.deb
Selecting previously unselected package linux-headers-4.14.0-041400.
(Reading database ... 364285 files and directories currently installed.)
Preparing to unpack linux-headers-4.14.0-041400_4.14.0-041400.201711122031_all.deb ...
Unpacking linux-headers-4.14.0-041400 (4.14.0-041400.201711122031) ...
Selecting previously unselected package linux-headers-4.14.0-041400-generic.
Preparing to unpack linux-headers-4.14.0-041400-generic_4.14.0-041400.201711122031_amd64.deb ...
Unpacking linux-headers-4.14.0-041400-generic (4.14.0-041400.201711122031) ...
Selecting previously unselected package linux-image-4.14.0-041400-generic.
Preparing to unpack linux-image-4.14.0-041400-generic_4.14.0-041400.201711122031_amd64.deb ...
Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/intel-microcode 4.14.0-041400-generic /boot/vmlinuz-4.14.0-041400-generic
Done.
Unpacking linux-image-4.14.0-041400-generic (4.14.0-041400.201711122031) ...
Setting up linux-headers-4.14.0-041400 (4.14.0-041400.201711122031) ...
Setting up linux-headers-4.14.0-041400-generic (4.14.0-041400.201711122031) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 4.14.0-041400-generic /boot/vmlinuz-4.14.0-041400-generic

I'm running 17.10, and the command fails to proceed further than this. I've waited overnight and still nothing. Does anyone know what's wrong or how to repair. Tried "sudo apt-get --fix-missing install" and "sudo dpkg --configure -a" to no avail.

Question information

Language:
English Edit question
Status:
Needs information
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2017-11-14
Last reply:
2017-11-14

Why are you installing the latest kernel? Does your hardware not work under the current kernel?

mark ricketts (sailnaked) said : #2

Hi actionparsnip, I first noticed the problem when I ran "sudo apt-get upgrade" and Ubuntu tried to install the 4.13.0.17 kernel. So the problem existed before I tried to install the 4.14 kernel. But, in answer to your question ... I've got a Hynix NVMe ssd drive that I want to use in my Lenovo P50 and the 4.14 kernel is supposed to provide better support.

OK cool. Just checking. The number of times who install kernels without knowing why or for no reason is astronomical.

What is the output of:

uname -a; lsb_release -a; df -h

Thanks

Can you help with this problem?

Provide an answer of your own, or ask mark ricketts for more information if necessary.

To post a message you must log in.