ubuntu 17.10 logs on to blank screen in dell vostro

Asked by drskartik on 2017-11-09

I have a Dell vostro which had ubuntu 16.04 installed and is working well. I did a upgrade to 17.04 and wanted to do afresh install of 17.10. I tried working on 17.10 booting with a usb drive. However I get a blank screen but I am able to work with an external monitor.
this is the output of lspci
lspci | grep VGA | cut -d " " -f 1 | xargs lspci -vv -s
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07) (prog-if 00 [VGA controller])
 Subsystem: Dell HD Graphics 520
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 279
 Region 0: Memory at d0000000 (64-bit, non-prefetchable) [size=16M]
 Region 2: Memory at c0000000 (64-bit, prefetchable) [size=256M]
 Region 4: I/O ports at f000 [size=64]
 [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
 Capabilities: <access denied>
 Kernel driver in use: i915
 Kernel modules: i915
Is there a problem with the display driver?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
drskartik
Solved:
2017-11-09
Last query:
2017-11-09
Last reply:
2017-11-09

Do you have the latest BIOS?

drskartik (drskartik) said : #2

Thanks I updated the BIOS and am able to see 17.10 on my laptop.