LG GH24NSB0 RW CD/DVD drive listed as 'read-only" by 14.04 LTS. Cannot write CDs orDVDs.

Asked by Humberto Jemma on 2017-11-07

I have an LG GH24NSB0 CD/DVD RW drive, but Ubuntu 14.04 LTS does not recognize it's writing capabilities. I currently can only read CDs and DVDs. The Ubuntu Disks utility recognizes the correct model (HL-DT-ST DVDRAM GH24NSB0 (LN00)), but lists it as '(Read-Only)'. When I insert any writable media, it show the drive as empty, so Brasero (or any other software) cannot write to it.

LG does not offer support for Linux in it's site. Can anyone help me with this issue?

Thank you,

Humberto Jemma

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Humberto Jemma
Solved:
2017-11-08
Last query:
2017-11-08
Last reply:
2017-11-08

Do you have the latest firmware in the drive?

Humberto Jemma (hjamariajemma) said : #3

L00. There is an updated version (L03) in LG's site, but the installer is
for Windows. I'm afraid to use it with Wine.

Humberto Jemma
(do meu celular)

Em 07/11/2017 21:58, "actionparsnip" <email address hidden>
escreveu:

> Your question #660462 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/660462
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> Do you have the latest firmware in the drive?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+question/660462
>
> You received this question notification because you asked the question.
>

It won't work in WINE. The installer needs raw hardware access which WINE doesn't give.

Is there no bootable media method you can use? Does the. Firmware update fix this kind of issue?

Humberto Jemma (hjamariajemma) said : #5

I don't know. As I said, LG doesn't support Linux, so there is no info on that in their site.

Humberto Jemma (hjamariajemma) said : #6

A friend, who happens to be an advanced Linux user, dropped by and performed some command line magic, and now the issue is solved. Please don't ask me for details. All he told me is that he 'forced' Ubuntu to reinstall the device drivers using shell commands. The Disks utility still lists the device as '(Read-Only)', but recognizes a blank disk when inserted, so Brasero could burn the image.

I consider the question closed even thou I would really like to know how to update the firmware to the latest version available.

Thank you actionparsnip for your support.