apt-get upgrade shows warning "couldn't be accessed by user '_apt'"

Asked by Ashvin Bhuttoo on 2017-11-07

Every time i run "apt-get upgrade", i get a warning at the end, i think it started doing that after i ran do-release-upgrade and that failed due to not enough space in /boot, that is also another issue.

//root@da3dalus:~#uname -a
Linux da3dalus.contaboserver.net 4.10.0-26-generic #30-Ubuntu SMP Tue Jun 27 09:30:12 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

//root@da3dalus:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 17.04
Release: 17.04
Codename: zesty

///Warning example:
root@da3dalus:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  linux-generic linux-headers-generic linux-image-generic
The following packages will be upgraded:
  libssl1.0.0 libssl1.0.0:i386 openssl
3 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Need to get 2,482 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://de.archive.ubuntu.com/ubuntu zesty-updates/main i386 libssl1.0.0 i386 1.0.2g-1ubuntu11.3 [911 kB]
Get:2 http://de.archive.ubuntu.com/ubuntu zesty-updates/main amd64 libssl1.0.0 amd64 1.0.2g-1ubuntu11.3 [1,081 kB]
Get:3 http://de.archive.ubuntu.com/ubuntu zesty-updates/main amd64 openssl amd64 1.0.2g-1ubuntu11.3 [491 kB]
Fetched 2,482 kB in 0s (7,710 kB/s)
Preconfiguring packages ...
(Reading database ... 262107 files and directories currently installed.)
Preparing to unpack .../libssl1.0.0_1.0.2g-1ubuntu11.3_i386.deb ...
De-configuring libssl1.0.0:amd64 (1.0.2g-1ubuntu11.2) ...
Unpacking libssl1.0.0:i386 (1.0.2g-1ubuntu11.3) over (1.0.2g-1ubuntu11.2) ...
Preparing to unpack .../libssl1.0.0_1.0.2g-1ubuntu11.3_amd64.deb ...
Unpacking libssl1.0.0:amd64 (1.0.2g-1ubuntu11.3) over (1.0.2g-1ubuntu11.2) ...
Preparing to unpack .../openssl_1.0.2g-1ubuntu11.3_amd64.deb ...
Unpacking openssl (1.0.2g-1ubuntu11.3) over (1.0.2g-1ubuntu11.2) ...
Setting up libssl1.0.0:amd64 (1.0.2g-1ubuntu11.3) ...
Setting up libssl1.0.0:i386 (1.0.2g-1ubuntu11.3) ...
Processing triggers for libc-bin (2.24-9ubuntu2.2) ...
Setting up openssl (1.0.2g-1ubuntu11.3) ...
Processing triggers for man-db (2.7.6.1-2) ...
W: Download is performed unsandboxed as root as file '/var/cache/apt/archives/partial/libssl1.0.0_1.0.2g-1ubuntu11.3_i386.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

Can someone tell me why i am getting this warning and why is "ubuntu11.3_i386.deb" appended to the path when only libssl was updated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Ashvin Bhuttoo
Solved:
2017-11-08
Last query:
2017-11-08
Last reply:
2017-11-07
Manfred Hampl (m-hampl) said : #1

The warning "W: Download is performed unsandboxed" is a known problem covered by Bug #1522675
It is just a warning and can be safely ignored.

And for the file libssl1.0.0_1.0.2g-1ubuntu11.3_i386.deb you have to understand the file naming standard of Debian.
There are three parts segregated by underscores.
The first one is the name of the package, the second one gives the exact version number (eventually extended by ...ubuntu...numbers denoting that there is a Ubuntu-specific modification), and the third part denotes the CPU architecture for which the package is usable.

Thanks for your reply Manfred