Cannot connect to Canon Pixma MG5150 printer after upgrade to Ubuntu 17.10

Asked by Christophe Lyon on 2017-11-05

Hello,

After I upgraded my computer (amd64) from Ubuntu 17.04 to 17.10, I can no longer use my Canon Pixma MG5150 printer.

The existing printer still appears as the default printer, but the documents do not get printed, despite it is active etc...

I tried to create another printer, choosing USB as connection method, and I'm offered with a prompt to open Ubuntu "Software" to install the relevant driver, but then I get to a page saying the needed driver was not found.

I was about to file a bug report against Ubuntu 17.10, but I think this does not belong to "supported software", hence I'm asking here.

I tried to download the drivers from Canon's website (http://fr.software.canon-europe.com/index.asp), and installed cnijfilter-common, cnijfilter-mg5100series, scangearmp-common and scangearmp-mg5100series from the tarball I downloaded, but with mixed luck.

Note that I had to force the install of cnijfilter-mg5100series, because it depends on libtiff4, while my machine now runs libtiff5.

At this stage the printer does not work, and I noticed this in the logs:
[ 135.171773] usblp0: removed
[ 135.192165] usblp 2-2:1.1: usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04A9 pid 0x1748

lsusb says:
 Bus 002 Device 002: ID 04a9:1748 Canon, Inc. Pixma MG5150

Later, I manually downloaded and installed libtiff4 from https://www.ubuntuupdates.org/package/core/precise/main/updates/libtiff4, because when I added a 'precise' entry to apt's sources.dist, I got a GPG error because of a missing pubkey.

With libtiff4 installed, I managed to execute the install.sh included in the cnijfilter tarball, which created a new printer, which does work. The remaining problem is that this driver does not offer all the options I used with the cups+gutenprint version.

What should I do to get the gutenprint driver to work?
Would this be a valid bug report?

Thanks

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2017-11-05
Last reply:

Can you help with this problem?

Provide an answer of your own, or ask Christophe Lyon for more information if necessary.

To post a message you must log in.