gnome-control-center not working

Asked by yash on 2017-11-05

Updated from 17.04 to 17.10 few days back and now I don't see any option to change any of my system settings. Tried launching gnome-control-center and switchboard. Logs details a re below -

~$ gnome-control-center
[INFO 13:07:47.920056] Application.vala:155: System Settings version: 2.0
[INFO 13:07:47.920108] Application.vala:157: Kernel version: 4.13.0-16-generic

** (process:18999): CRITICAL **: string_contains: assertion 'self != NULL' failed

** (process:18999): CRITICAL **: string_contains: assertion 'self != NULL' failed
[ERROR 13:07:48.055726] [GLib-GIO] Settings schema 'org.pantheon.desktop.gala.animations' is not installed
/usr/bin/gnome-control-center: line 20: 18992 Trace/breakpoint trap (core dumped) switchboard $switchboard_options $requested_plug

~$ switchboard -d
[INFO 13:08:32.171659] Application.vala:155: System Settings version: 2.0
[INFO 13:08:32.171709] Application.vala:157: Kernel version: 4.13.0-16-generic
[DEBUG 13:08:32.222574] OnlineAccounts.vala:290: Activating Online Accounts plug
[DEBUG 13:08:32.223023] Password.vala:41: OnlineAccouts: Activating Password plugin
[DEBUG 13:08:32.223314] fastmail.vala:42: OnlineAccouts: Activating FastMail plugin
[DEBUG 13:08:32.223617] LastFM.vala:41: OnlineAccouts: Activating LastFM plugin
[DEBUG 13:08:32.223915] Email.vala:42: OnlineAccouts: Activating Mail plugin
[DEBUG 13:08:32.224725] PlugsManager.vala:91: network-pantheon-online-accounts registered
[DEBUG 13:08:32.229132] Plug.vala:207: Activating Network plug
[DEBUG 13:08:32.281876] Settings.vala:163: Loading settings from schema 'org.gnome.system.proxy'
[DEBUG 13:08:32.282394] Settings.vala:163: Loading settings from schema 'org.gnome.system.proxy.ftp'
[DEBUG 13:08:32.282643] Settings.vala:163: Loading settings from schema 'org.gnome.system.proxy.http'
[DEBUG 13:08:32.282906] Settings.vala:163: Loading settings from schema 'org.gnome.system.proxy.https'
[DEBUG 13:08:32.283136] Settings.vala:163: Loading settings from schema 'org.gnome.system.proxy.socks'
[DEBUG 13:08:32.283435] PlugsManager.vala:91: pantheon-network registered
[DEBUG 13:08:32.284651] Plug.vala:123: Activating Sharing plug
[DEBUG 13:08:32.284749] PlugsManager.vala:91: pantheon-sharing registered
[DEBUG 13:08:32.285981] DisplayPlug.vala:211: Activating Display plug
[DEBUG 13:08:32.286073] PlugsManager.vala:91: pantheon-display registered
[DEBUG 13:08:32.286969] keyboard.vala:51: Activating Keyboard plug
[DEBUG 13:08:32.287057] PlugsManager.vala:91: hardware-pantheon-keyboard registered
[DEBUG 13:08:32.287929] mouse-touchpad.vala:130: Activating Mouse-Touchpad plug
[DEBUG 13:08:32.288062] PlugsManager.vala:91: pantheon-mouse-touchpad registered
[DEBUG 13:08:32.289223] Plug.vala:388: Activating Power plug
[DEBUG 13:08:32.296221] Battery.vala:69: battery path:/org/freedesktop/UPower/devices/battery_BAT0 , its a laptop, dbus connected
[DEBUG 13:08:32.299674] PowerSupply.vala:58: power supply path: (null) dbus connected

** (process:19066): CRITICAL **: string_contains: assertion 'self != NULL' failed

** (process:19066): CRITICAL **: string_contains: assertion 'self != NULL' failed
[DEBUG 13:08:32.309054] CliCommunicator.vala:102: lid_close_dock:ignore
[DEBUG 13:08:32.309186] CliCommunicator.vala:107: lid_close:suspend
[DEBUG 13:08:32.311947] PlugsManager.vala:91: system-pantheon-power registered
[DEBUG 13:08:32.315195] Plug.vala:199: Activating Printers plug
[DEBUG 13:08:32.315322] PlugsManager.vala:91: pantheon-printers registered
[DEBUG 13:08:32.316125] Plug.vala:109: Activating Applications plug
[DEBUG 13:08:32.316251] PlugsManager.vala:91: personal-pantheon-applications registered
[DEBUG 13:08:32.318292] Plug.vala:193: Activating Locale plug
[DEBUG 13:08:32.318442] PlugsManager.vala:91: system-pantheon-locale registered
[DEBUG 13:08:32.320836] Plug.vala:127: Activating Security & Privacy plug
[DEBUG 13:08:32.321141] PlugsManager.vala:91: pantheon-security-privacy registered
[DEBUG 13:08:32.321988] Plug.vala:137: Activating Accessibility plug
[DEBUG 13:08:32.322175] Settings.vala:163: Loading settings from schema 'org.gnome.desktop.interface'
[DEBUG 13:08:32.322543] Settings.vala:163: Loading settings from schema 'org.gnome.desktop.a11y.keyboard'
[DEBUG 13:08:32.322988] Settings.vala:163: Loading settings from schema 'org.gnome.desktop.a11y'
[DEBUG 13:08:32.323165] Settings.vala:163: Loading settings from schema 'org.gnome.desktop.a11y.magnifier'
[DEBUG 13:08:32.323557] Settings.vala:163: Loading settings from schema 'org.gnome.desktop.a11y.applications'
[DEBUG 13:08:32.323752] Settings.vala:163: Loading settings from schema 'org.gnome.desktop.wm.preferences'
[DEBUG 13:08:32.323910] Settings.vala:163: Loading settings from schema 'org.gnome.settings-daemon.peripherals.mouse'
[DEBUG 13:08:32.324026] Settings.vala:163: Loading settings from schema 'org.gnome.desktop.a11y.mouse'
[DEBUG 13:08:32.324270] Settings.vala:163: Loading settings from schema 'org.gnome.settings-daemon.plugins.media-keys'
[ERROR 13:08:32.324382] [GLib-GIO] Settings schema 'org.pantheon.desktop.gala.animations' is not installed
Trace/breakpoint trap (core dumped)

Here are the details of my PPA repo-

~$ ls /etc/apt/sources.list.d
chrome-remote-desktop.list
chrome-remote-desktop.list.distUpgrade
chrome-remote-desktop.list.save
elementary-os-ubuntu-stable-xenial.list
elementary-os-ubuntu-stable-xenial.list.save
fingerprint-ubuntu-fingerprint-gui-xenial.list
fingerprint-ubuntu-fingerprint-gui-xenial.list.distUpgrade
fingerprint-ubuntu-fingerprint-gui-xenial.list.save
google-chrome-beta.list
google-chrome-beta.list.distUpgrade
google-chrome-beta.list.save
google-chrome.list
google-chrome.list.distUpgrade
google-chrome.list.save
heroku.list
heroku.list.distUpgrade
heroku.list.save
webupd8team-ubuntu-haguichi-wily.list
webupd8team-ubuntu-haguichi-wily.list.distUpgrade
webupd8team-ubuntu-haguichi-wily.list.save

Will appreciate any help to resolve this.
Thanks.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2017-11-05
Last reply:
2017-11-05
Manfred Hampl (m-hampl) said : #1

Please provide the output of the following diagnostic commands

uname -a
lsb_release -crid
apt-cache policy gnome-control-center

yash (yashx1) said : #2

Thanks for having a look Hampl.
Here are the details -

$ uname -a
Linux mjolnir 4.13.0-16-generic #19-Ubuntu SMP Wed Oct 11 18:35:14 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 17.10
Release: 17.10
Codename: artful

$ apt-cache policy gnome-control-center
gnome-control-center:
  Installed: 1:3.26.1-0ubuntu5
  Candidate: 1:3.26.1-0ubuntu5
  Version table:
 *** 1:3.26.1-0ubuntu5 500
        500 http://archive.ubuntu.com/ubuntu artful-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:3.26.1-0ubuntu4 500
        500 http://archive.ubuntu.com/ubuntu artful/main amd64 Packages

Manfred Hampl (m-hampl) said : #3

It seems to me that the offending package is switchboard, which is part of elementary OS.
We cannot help with that.

yash (yashx1) said : #4

Thanks Hampl.
Though I am unable to open any kind of manager applet/tool to perform anything after upgrading to 17.10 , so is this only issue with switchboard or is this a issue with the upgrade ?

What is the output of:

cat -n /etc/apt/sources.list

Thanks

Manfred Hampl (m-hampl) said : #6

I do not know what switchboard is and why it would interfere with the execution of gnome-control-senter.
The only thing I know is that it is not an Ubuntu-provided program.

yash (yashx1) said : #7

Hi Andrew,
Thanks for taking a look.
Please find the output below -

$ cat -n /etc/apt/sources.list
     1 deb http://archive.ubuntu.com/ubuntu artful main
     2 deb http://security.ubuntu.com/ubuntu/ artful-security main
     3 deb http://archive.ubuntu.com/ubuntu artful-updates main

Can you help with this problem?

Provide an answer of your own, or ask yash for more information if necessary.

To post a message you must log in.