Unable to install g++6 on ubuntu artful

Asked by Arnaud Buy on 2017-10-13

Hello,

After an upgrade from 17.04 to 17.10, i cannot find g++6 anymore.

When i try to install g++6 from sudo apt install, i get this message :

Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'liblablgtk2-ocaml-9leg6:i386' for regex 'g++6'
Note, selecting 'libecpg6' for regex 'g++6'
Note, selecting 'libjpeg62-dbg' for regex 'g++6'
Note, selecting 'libjpeg62-dev' for regex 'g++6'
Note, selecting 'libjpeg62' for regex 'g++6'
Note, selecting 'liblablgtk2-ocaml-dev-9leg6:i386' for regex 'g++6'
Note, selecting 'libxmltooling6' for regex 'g++6'
Note, selecting 'libatd-ocaml-g6n02' for regex 'g++6'
Note, selecting 'libatd-ocaml-dev-g6n02' for regex 'g++6'
Note, selecting 'libcfg6' for regex 'g++6'
Note, selecting 'ocaml-ulex-xvg63:i386' for regex 'g++6'
Note, selecting 'libjpeg62-turbo' for regex 'g++6'
Note, selecting 'libatd-ocaml' instead of 'libatd-ocaml-g6n02'
Note, selecting 'libatd-ocaml-dev' instead of 'libatd-ocaml-dev-g6n02'
Note, selecting 'liblablgtk2-ocaml:i386' instead of 'liblablgtk2-ocaml-9leg6:i386'
Note, selecting 'liblablgtk2-ocaml-dev:i386' instead of 'liblablgtk2-ocaml-dev-9leg6:i386'
Note, selecting 'ocaml-ulex:i386' instead of 'ocaml-ulex-xvg63:i386'
libatd-ocaml is already the newest version (1.1.2-1build3).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 liblablgtk2-ocaml:i386 : Depends: ocaml-base-nox-4.04.0:i386
 liblablgtk2-ocaml-dev:i386 : Depends: libgtk2.0-dev:i386 but it is not going to be installed
                              Depends: libglade2-dev:i386 but it is not going to be installed
                              Depends: libgtkspell-dev:i386 but it is not going to be installed
                              Depends: ocaml-nox-4.04.0:i386
                              Recommends: liblablgtk2-ocaml-doc:i386 but it is not installable
 ocaml-ulex:i386 : Depends: ocaml-findlib:i386 but it is not going to be installed
                   Depends: libcamlp4-ocaml-dev-rknu1:i386
                   Depends: ocaml-nox-4.04.0:i386
E: Unable to correct problems, you have held broken packages.

What can i do ?

Arnaud

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2017-10-13
Last query:
2017-10-13
Last reply:
2017-10-13

I suggest you report a bug. Artful is not ready and not stable

Arnaud Buy (asnod) said : #2

ok thanks

Best Manfred Hampl (m-hampl) said : #3

I assume that the package that you want is named g++-6 and not g++6

Arnaud Buy (asnod) said : #4

Thanks Manfred Hampl, that solved my question.