unable to copy files/videos to some New HD's

Asked by Rich.b on 2017-10-09

How do enable these new drives to receive files/videos
I have had installed 2 new 2 TB drives but am not able copy files/videos too.
I can copy files/videos to external HD OK.

please can you advise.
Thanks

Richard

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2017-11-06
Last reply:
2017-11-06

Did you partition and format them?
If so, what file system have you used?
What is the output of:

sudo parted -l; lsb_release -a; uname -a; mount

Thanks

Rich.b (aybi30) said : #2

richard@richard-H81M-S2H:~$ sudo parted -l; lsb_release -a; uname -a; mount
[sudo] password for richard:
Model: ATA KINGSTON SHSS37A (scsi)
Disk /dev/sda: 480GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
 1 1049kB 525MB 524MB primary ntfs boot
 2 525MB 157GB 156GB primary ntfs
 3 157GB 319GB 162GB extended lba
 5 157GB 311GB 154GB logical ext4
 6 311GB 319GB 8469MB logical linux-swap(v1)

Model: ATA WDC WD20PURX-64P (scsi)
Disk /dev/sdb: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
 1 1016kB 944GB 944GB extended lba
 5 1049kB 524GB 524GB logical ntfs
 6 524GB 944GB 419GB logical ext4
 2 944GB 2000GB 1057GB primary ext4

Model: ATA WDC WD20PURX-64P (scsi)
Disk /dev/sdc: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
 1 1049kB 2000GB 2000GB primary ext4

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial
Linux richard-H81M-S2H 4.10.0-35-generic #39~16.04.1-Ubuntu SMP Wed Sep 13 09:02:42 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=4006412k,nr_inodes=1001603,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=805736k,mode=755)
/dev/sda5 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=28,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=13450)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=805736k,mode=700,uid=1000,gid=1000)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
richard@richard-H81M-S2H:~$

Are the 2 drives internal drives?

They have been formatted to Ext4 which is good.

Rich.b (aybi30) said : #4

A 1/ Yes
A 2/ I think so ?

Rich.b (aybi30) said : #5

I am using partitions on one of the drives ok but not able to get /dev/sbd2 and /dev/sdc1 I believe.

You can add the partitions to /etc/fstab

It depends how you want to use them. Is it just for data storage or do you have a use in mind?

Rich.b (aybi30) said : #7

You can add the partitions to /etc/fstab - This is in folders, not sure about this or how this is done ?

It depends how you want to use them. Is it just for data storage or do you have a use in mind? - Mainly back up Ubuntu and storing films/videos.

So how do enable copy/paste from by video folder in say /dev/sdb6 (ext4) to say /dev/sdb2 (ext) or /dev/sdc1

Rich.b (aybi30) said : #8

I can copy home/videos (/dev/sda5) to /dev/sdb6 415GB ext4 OK

But not to /dev/sdc1 ext4 which all most empty .

Why is this ?

Thanks Andrew

Do you want one to be backup and one for videos?

Once I have this I can give some fstab entries.

Rich.b (aybi30) said : #11

Sdc1 has only one partition as you can see.

I could divide this into 2 and use this for back up and videos

 or

Use sdc1 for videos only.

and use sdb6 for back up.

What do you think?

Your choice. I don't know how much data you intend to backup or store for videos. You can use GPartEd to arrange your partitions. We can then mount them in a folder in your user's /home for easy access (or centrally if you have multiple users on the system).

It's a very flexible system.

Rich.b (aybi30) said : #13

I usually store videos in video folder and them when we have seen them either delete them or save a copy to another folder on another drive for use some years later ( or give copy to the family). Save as data. about 100GB video folder.

Back up for Ubuntu16.04 I would like to save on 1TB internal HD which has 428.9GB free and each back up for Ubuntu has been about 14GB.

In the 2TB HD there are no folders and no options to add one - How do I do this please?

Thank again Andrew

Use GParted to partition the drives. Its pretty self explanatory but use the "Gparted" menu in the application to change the device being manipulated and plan your partitions.

You can also label them here to make things clearer.

Running the below (you don't need to alter it)

mkdir $HOME/BackupFolder
sudo mount /dev/sdc1 $HOME/BackupFolder
sudo chown $USER:USER $HOME/BackupFolder

Will make you a folder /home/$USER/BackupFolder and mount the 2Tb /dev/sdc1 to it. You can then put data on it as you wish.

Is this what you want? If so then run:

sudo blkid

and give the output. We can then add a line to /etc/fstab to mount it there every time you boot the system.

Rich.b (aybi30) said : #16

What did I do Wrong here?

richard@richard-H81M-S2H:~$ mkdir $HOME/BackupFolder
richard@richard-H81M-S2H:~$ sudo mount /dev/sdc1 $HOME/BackupFolder
[sudo] password for richard:
richard@richard-H81M-S2H:~$ sudo chown $USER:USER $HOME/BackupFolder
chown: invalid group: ‘richard:USER’
richard@richard-H81M-S2H:~$

Them type sudo blkid

richard@richard-H81M-S2H:~$ sudo blkid
/dev/sda1: LABEL="System Reserved" UUID="329C90AF9C906F5B" TYPE="ntfs" PARTUUID="325a6e36-01"
/dev/sda2: UUID="08D4A2F2D4A2E0E4" TYPE="ntfs" PARTUUID="325a6e36-02"
/dev/sda3: UUID="005EF74C5EF738CC" TYPE="ntfs" PARTUUID="325a6e36-03"
/dev/sda5: UUID="f535e51d-b11a-491a-a87f-4ec51b9638d7" TYPE="ext4" PARTUUID="325a6e36-05"
/dev/sda6: UUID="be08b1bc-fe2e-4a57-bc76-61e425ebcf81" TYPE="swap" PARTUUID="325a6e36-06"
/dev/sdb2: UUID="d2eff4cd-78e6-d201-50eb-f4cd78e6d201" TYPE="ext4" PARTUUID="5a05f99a-02"
/dev/sdb5: LABEL="New Volume" UUID="01D2E5E089B12A50" TYPE="ntfs" PARTUUID="5a05f99a-05"
/dev/sdb6: UUID="10ed14f1-ae80-4017-849e-e94c2e510081" TYPE="ext4" PARTUUID="5a05f99a-06"
/dev/sdc1: UUID="db3780b5-dce5-d201-d035-80b5dce5d201" TYPE="ext4" PARTUUID="08acd8a6-01"
richard@richard-H81M-S2H:~$

Rich.b (aybi30) said : #17

What did I do wrong here ? See above.

How now do I set-up back up to my 2TB HD?

Thank you for any help.

Richard

Rich.b (aybi30) said : #18

Tried to to back up, but not sure were too though ?
Backup Failed.
Got this Error msg:-

Permission denied when trying to create ‘/duplicity-full.20171101T102601Z.vol1.difftar.gpg’.

NTFS doesn't store Linux file permissions. It's access needs setting at mount time.
I suggest you run a full chkdsk in Windows to make sure the file system is consistent

Manfred Hampl (m-hampl) said : #20

There was an error in one of the previous commands, and I am not sure whether it is already corrected:

sudo chown $USER:USER $HOME/BackupFolder
chown: invalid group: ‘richard:USER’

It should have been

sudo chown $USER:$USER $HOME/BackupFolder

(with an additional $ sign)

Rich.b (aybi30) said : #21

So Manfred should I have put 'richard:USER' somewhere in the terminal text?

and if how should it look?

Thank you Manfred for your help

Manfred Hampl (m-hampl) said : #22

You gave the wrong command
"sudo chown $USER:USER $HOME/BackupFolder"
and the system responded with the error message
"chown: invalid group: ‘richard:USER’"

What you should have done (and probably should do now) is giving the correct command

sudo chown $USER:$USER $HOME/BackupFolder

Rich.b (aybi30) said : #24

Did this again today:

sudo chown $USER:$USER $HOME/BackupFolder

Tried to back up on my 20.TB Volume

Backup Failed:

Permission denied when trying create'/ duplicity-full 20171105T122221z.vol1.difftar.gpg'.

Manfred Hampl (m-hampl) said : #25

What is the output of the commands

ls -ld ~/BackupFolder
grep BackupFolder /etc/fstab

Rich.b (aybi30) said : #26

richard@richard-H81M-S2H:~$ ls -ld ~/BackupFolder
drwxrwxr-x 2 richard richard 4096 Oct 22 10:48 /home/richard/BackupFolder
richard@richard-H81M-S2H:~$ grep BackupFolder /etc/fstab

Rich.b (aybi30) said : #27

This is my 2TB HD

richard@richard-H81M-S2H:/media/richard/db3780b5-dce5-d201-d035-80b5dce5d201$

Can't open or generate any folders or see anything in this HD

Manfred Hampl (m-hampl) said : #28

How do you mount the extra hard disk?

In one of the previous messages you want to access it as /home/richard/BackupFolder but your past output shows it mounted as /media/richard/db3780b5-dce5-d201-d035-80b5dce5d201 ???

Rich.b (aybi30) said : #29

Sorry I am confused. Would like to have a backup on this HD and also my backups.
Can you please advise.
Thanks.
Richard

Sent from TypeApp<http://www.typeapp.com/r?b=11053>
On 6 Nov 2017, at 13:23, Manfred Hampl <<email address hidden><mailto:<email address hidden>>> wrote:

Your question #659137 on Ubuntu changed:
https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fanswers.launchpad.net%2Fubuntu%2F%2Bquestion%2F659137&data=02%7C01%7Cblairs_electrica%40hotmail.com%7C5156f81675fd444b22bc08d525199059%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636455714075967588&sdata=%2Fb8LXCsjZqsmy1VH0Qjdil5WKnT6FWtp%2Fs5iGFMgAsY%3D&reserved=0

    Status: Open => Needs information

Manfred Hampl requested more information:
How do you mount the extra hard disk?

In one of the previous messages you want to access it as
/home/richard/BackupFolder but your past output shows it mounted as
/media/richard/db3780b5-dce5-d201-d035-80b5dce5d201 ???

Rich.b (aybi30) said : #30

So how do I use this 2TB HD for both please.

Sent from TypeApp<http://www.typeapp.com/r?b=11053>
On 6 Nov 2017, at 13:23, Manfred Hampl <<email address hidden><mailto:<email address hidden>>> wrote:

Your question #659137 on Ubuntu changed:
https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fanswers.launchpad.net%2Fubuntu%2F%2Bquestion%2F659137&data=02%7C01%7Cblairs_electrica%40hotmail.com%7C5156f81675fd444b22bc08d525199059%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636455714075967588&sdata=%2Fb8LXCsjZqsmy1VH0Qjdil5WKnT6FWtp%2Fs5iGFMgAsY%3D&reserved=0

    Status: Open => Needs information

Manfred Hampl requested more information:
How do you mount the extra hard disk?

In one of the previous messages you want to access it as
/home/richard/BackupFolder but your past output shows it mounted as
/media/richard/db3780b5-dce5-d201-d035-80b5dce5d201 ???

Manfred Hampl (m-hampl) said : #31

If you do not want to do manual mounting whenever you want to use the 2TB disk, you have to create a directory as mount pint for it, and create a suitable entry in /etc/fstab.
This is what actionparsnip mentioned already on October 9 in response #6.

Rich.b (aybi30) said : #32

Sorry I missed this :- You can add the partitions to /etc/fstab

So how do I set this up?

also the other Partition on the second HD which is 1.1TB

again thank you your help Manfred

Can you help with this problem?

Provide an answer of your own, or ask Rich.b for more information if necessary.

To post a message you must log in.