Mozilla Crashing all of the time

Asked by davidzaq1 on 2017-10-08

Hello ,

I have Mozilla Firefox and using Ubuntu 16.04.
I have this problem where the site keeps crashing.

Message: Gah. Your tab just crashed.

The message allows for the page to be restarted but when the page is restarted, it crashes again.
This goes on for a long time until I close it and go to chrome.

One of the sites I visited said to start Firefox in safe mode with add-ons disabled. I did this and there was no more crashes.

I went to my add-ons and I have no add-ons enabled, actually, I have no add-ons at all.

I have been to the software center, uninstalled Firefox and reinstalled it but still having the problems.

Is there a way to fix this.? I think it happened with the last Firefox update.

Thank you for your help

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
davidzaq1
Solved:
2017-10-21
Last query:
2017-10-21
Last reply:
2017-10-15

If you rename ~/.mozilla

(I assume you don't use Thunderbird for email)

Then run the browser, you will get vanilla settings. Does it work OK?

Manfred Hampl (m-hampl) said : #2

You say that you do not have any add-ons installed, but do you have plugins installed?
If yes, which ones, and what are their settings?

davidzaq1 (david3a9x) said : #3

no plug-ins are installed either.
When Ubuntu updated to the new version of Firefox it seemed to have removed all the settings I originally had.
So now, there are no add-ons and no plug-ins set up at all.

Did renaming the folder help?

davidzaq1 (david3a9x) said : #5

renaming what folder? I do not understand

I'll make it easier. Close all insurances of the browser and open a terminal and run:

mv ~/.mozilla ~/.mozilla_old

Then rerun the browser.

Is it OK?

davidzaq1 (david3a9x) said : #7

Yes it is working now and doesnt crash at all but now Firefox i telling me my browser is out of date and to update to the newer version for better security. I wanted to fix the new one not go back to the old one.

Isn't there a way to have the newer version and make it work right?

davidzaq1 (david3a9x) said : #8

Hello,

I am supplying some additional information. I recently posted that the old version of Firefox was working.
Sadly, it is not.

The program is still crashing the tabs.

I do not know what is going on with this browser. It is not the entire browser, only when I open a tab.

As I said before, if I hope the browser with add-ons disabled, the browser is fine and no crashing.

II have no add-ons at all so I am not sure what is happening here.

What is the output of:

lsb_release -a; uname -a; apt-cache policy firefox

Thanks

davidzaq1 (david3a9x) said : #10

Hello,

Here is the out put from the above command.

Thank you.

$ lsb_release -a; uname -a; apt-cache policy firefox
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial
Linux roo2 4.4.0-97-generic #120-Ubuntu SMP Tue Sep 19 17:28:18 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
firefox:
  Installed: 56.0+build6-0ubuntu0.16.04.2
  Candidate: 56.0+build6-0ubuntu0.16.04.2
  Version table:
 *** 56.0+build6-0ubuntu0.16.04.2 500
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     45.0.2+build1-0ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

davidzaq1 (david3a9x) said : #11

Hello,

I wanted to add some additional information.

It seems there are certain tabs that crash more than others in Firefox.
Yahoo for example crashes every time I get to the box where I put in my password.
The tab will crash 50 times in a row at the same spot until I put the settings into run in safe mode with no add-ons. Then it works fine.
Since this is now an older version of firefox that you reset for me, there are no add-ons at all.

Other tabs crash the same way, at the same points and also work one computer is put into safe mode.

It is really strange. This never happened until Ubuntu did the last firefox upgrade to the next version.

davidzaq1 (david3a9x) said : #12

I just fixed the problem.

Mozilla posted a fix on their forum page it seems that there some new multi process feature in Firefox. in the new

version.Normally the new feature is an advantage. The odd Gah message indicate that a tab has crashed but the browser itself should continue working as normal.

Pre release versions of Firefox have easier methods of turning this feature off or adjusting its settings but for now: Disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

Son on a blank Mozilla Tab I went to about:config

and changed the settings to the following:

browser.tabs.remote.autostart = false
browser.tabs.remote.autostart.2 = false

Restarted Firefox and this fixed the problem.

Hopes this helps someone else.

Thanks.