How to turn off auto-yes in fsck.ext4?

Asked by Dima on 2017-10-07

Seems like I've tuned something (in systemd or in /etc/default/rcS, but there is no rcS file) to autofix fs errors on boot.
And now I can't disable auto-yes for manual fsck-ing. So seems like I should to disable something for whole system for proper manual test. I've searched in /etc/* for any mentions of fsck and I've found nearly nothing.
(For fsck-ing I used this command: "fsck.ext4 -c /dev/sdc2". As you can see there is no -y option, but auto-yes is enabled.)

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Dima
Solved:
2017-10-07
Last query:
2017-10-07
Last reply:
Dima (dima2017) said : #1

Seems like auto-yes disabled somehow by itself, but I am not sure is it disabled for badblocks events too.