Ubuntu 17.10 full disk encryption + Nvidia drivers not working on boot

Asked by Maraschin on 2017-10-07

I've installed ubuntu 17.10 with full disk encryption and then installed the nvidia drivers. when I boot the computer I will get the graphics interface to enter the encryption key but the system will stop to work. Basically I'm not able to enter the key! I've to restart in safe mode to be able to enter the key, after that I can just resume the boot and all works.

There seems to be some issues with the initial boot screen and nvidia drivers... I'm not able to press any combination of Control+Alt+Fx key to get any extra info about what is going on.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2017-10-07
Last reply:
2017-10-07

When you type your password you get no feedback. Just type your password and hit ENTER.

If that is still an issue then I suggest you report a bug. Artful is not ready and not stable

Maraschin (carlo-maraschin) said : #3

Sorry Andrew, I'm not that novice ... :)
No, it doesn't work at all... It hangs!
A work around: Install the server version, from there install the desktop, nvidia-drivers, etc... than it will not have the nice graphics interface on boot - there I can enter the password and ubuntu will start.
If I install the desktop version - no it doesn't work!

Can you help with this problem?

Provide an answer of your own, or ask Maraschin for more information if necessary.

To post a message you must log in.