New installation - problem with partitions

Asked by Ralph Palmer on 2017-10-06

I am trying to do a clean (not side-by-side) install of <ubuntu-16.04.3-desktop-amd64> on a Windows 10 machine (eliminating Win10). I am using a disk I created using the iso. I planned to partition the hard drive (~120 Gb) into 5 partitions (no /boot partition), but after multiple failures, tried 6 partitions, divided :
/boot 1 Gb primary Ext4
/ 15 Gb logical Ext4
/var 10 Gb logical Ext4
/tmp 7 Gb logical Ext4
/home 15 Gb logical Ext4
/swap 15 Gb logical Ext4
which would leave a little free space. I wanted to put /swap right after /, but had no success, so I put /swap at the end.
Each time I tried, I got multiple messages :
(x) Warning!
     Error fsyncing/closing /dev/sda: input/output error
When I tried "retry", nothing happened. I finally tried
>ignore
and got
(x) Failed to creat a swap space
     The creation of swap space in partition #6 of SCSI 2 (0,0,0) (sda) failed.
Eventually, however, Ubuntu did load. I could get the desktop GUI. However, it looked like Ubuntu was loaded entirely into /. I could see empty partitions in the column on the left of the desktop. As "Guest", I can see :

Computer (folders, incl. bin, boot, cdrom, dev, etc, home . . . root, . . .)
10 GB Volume
200 GB Volume (/home)
7.2 GB Volume
999 MB Volume

Now, when I try to log in, Ubuntu accepts my password, but I get a momentary screen with 40 or 50 lines, all beginning with [OK], then I'm back at the login screen.
I have an Install disk..
If I can get to the desktop, can I (and is it safe to) simply move /var, /tmp, and /home to empty partitions?
If not, how can I repartition?
How can I get swap onto a different partition? (I'm not sure it isn't now, since I can't access the desktop.
Thanks for your time and your help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Ralph Palmer
Solved:
2017-10-06
Last query:
2017-10-06
Last reply:
2017-10-06

Is the disk healthy? Run an fsck from liveCD to test

Ralph Palmer (palmer-r-violin) said : #2

I think I'm all set. I burned a new .iso, made root the primary partition (and /boot logical), and installed. I haven't rebooted yet, just re-started Ubuntu.
I have now restarted the computer and logged in!
Sorry for the noise.

Ralph Palmer (palmer-r-violin) said : #3

Please see the above messsage.