Login Crash after newest 17.10 update

Asked by Alex GOOD HEARTS Organisation on 2017-10-06

Updating this morning my (usually daily updated) ubuntu 17.10 beta (the badly needed download of fixed Thunderbird took a bit of time). While waiting - updater still running - I changed a setting in System Monitor/System Load indicator: changed width from 100 to 400 pixels. Then restarting the System Monitor Indicator app - system update was still running. Maybe a coincidence, but as soon as the System Monitor Indicator opened, the whole session abruptly closed, I landed at login. I tried logging in as usual through Gnome/Wayland (default) but after turning purple it is jumping back to login screen. So i tried x-Org login. My desktop background image shows for 1 second, then back to login as well. What can I do? I really need some data from the machine and actually would just like to continue using and life-testing. Please help, thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2017-10-06
Last query:
2017-10-06
Last reply:
2017-10-06

I suggest you report a bug. Artful is not ready and not stable.

Check the ownership of the files in $HOME and make sure the file systems have free space. You'll probably want to drop to TTY1 and read the logs in /var/log to see what is going on.

Update your bug with your findings

Best Manfred Hampl (m-hampl) said : #3

Doing beta testing on a machine with important data is no good idea.

Some options to access your files:

You might try selecting an older kernel version from the grub menu.
Or you could try logging in to a virtual terminal (ctrl-alt-F1) to copy your data to an external storage medium.
Or you could use a different machine for a remote login (e.g. ssh).
Or you boot an Ubuntu installer from DVD or bootable USB stick in the "Try Ubuntu without installing" mode, mount the hard disk and access your data.

thanks, you guys, am not yet enough tech savvy to report logs through TTY1, but tried Manfred's stuff:
- older Kernel didn't help
- ssh refused to work
- safed data via a usb-stick
- tried install from freshly sucked 17.10 as update, update part of it didn't work
> installed afresh, updated, now ok, thanks again.

Thanks Manfred Hampl, that solved my question.