package rsyslog-pgsql 7.4.4-1ubuntu2.7 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Asked by michael on 2017-10-05

package rsyslog-pgsql 7.4.4-1ubuntu2.7 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Is this a bug? If not, how do I fix it?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
michael
Solved:
2017-10-08
Last query:
2017-10-08
Last reply:
2017-10-08
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes please provide the output of the commands (to be executed in a terminal window)

uname -a
lsb_release -crid
sudo dpkg --configure -a
sudo dpkg --audit

michael (yellupcm-gmail) said : #2

Manfred
Sorry for lack of information, was having a bad day. I knew you would need it.

uname -a
Linux 16 4.4.0-96-generic #119-Ubuntu SMP Tue Sep 12 14:59:54 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial

sudo dpkg --configure -a
no response

sudo dpkg --audit
also no response

michael (yellupcm-gmail) said : #3

Manfred
I found many bugs that were similar, put not same. Should I file new bug?

Manfred Hampl (m-hampl) said : #4

If "sudo dpkg --configure -a" and "sudo dpkg --audit" do not produce any output, then the problem must already have been resolved.

For verification:
What is the output of the commands

sudo apt-get update
sudo apt-get dist-upgrade

michael (yellupcm-gmail) said : #5

michael@16:~$ sudo apt-get update
[sudo] password for michael:
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://dl.google.com/linux/chrome/deb stable Release
Hit:3 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu xenial InRelease
Hit:5 http://ppa.launchpad.net/nowrep/qupzilla/ubuntu xenial InRelease
Hit:6 http://ppa.launchpad.net/rednotebook/stable/ubuntu xenial InRelease
Hit:7 http://archive.canonical.com/ubuntu xenial InRelease
Get:8 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Get:9 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [60.2 kB]
Get:10 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [62.6 kB]
Get:11 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [49.2 kB]
Hit:12 https://deb.opera.com/opera-stable stable InRelease
Get:13 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [69.7 kB]
Hit:14 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Get:15 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Get:16 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [305 kB]
Get:17 http://us.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [213 kB]
Get:18 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [172 kB]
Get:19 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [234 kB]
Get:20 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [5,888 B]
Fetched 1,376 kB in 11s (118 kB/s)
Reading package lists... Done

michael@16:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Manfred Hampl (m-hampl) said : #6

There is no error shown any more.

As a final check, what is the output of the command

apt-cache policy rsyslog-pgsql

michael (yellupcm-gmail) said : #7

michael@16:~$ apt-cache policy rsyslog-pgsql
rsyslog-pgsql:
  Installed: 8.16.0-1ubuntu3
  Candidate: 8.16.0-1ubuntu3
  Version table:
 *** 8.16.0-1ubuntu3 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        100 /var/lib/dpkg/status

Manfred
I reinstall optional addons. All worked except the two that had SQL. Removed them, seems OK now.

michael (yellupcm-gmail) said : #9

Thank You Manfred Hampl, problem solved.