HP Printer won't print in Ubuntu 16-04

Asked by peter ratcliffe on 2017-09-30

I have two HP printers, a LasefJetP1006 which is a few years old, and a LaserJetP1102 which is younger. Both appear in the printer icon in system settings printer. Neither will print anything. How do I find out if the fault is in the computer, the software or the printer.

With thanks, Peter Ratcliffe.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2017-10-03
Last query:
2017-10-03
Last reply:
2017-10-02

How do they connect to the system? Are they USB, Parallel, Network printers, Bluetooth printers?

What is the output:

lsb_release -a; uname -a; lsusb; apt-cache policy hplip

Thanks

Please execute the following bash shell script to replace the buggy hplip drivers with the foo2zjs and foo2xqx drivers.
This script should provide drivers for both of your HP printers.

 sudo apt-get update
 sudo apt-get remove hplip cups-filters cups hplip-data system-config-printer-udev
 sudo apt-get install build-essential tix groff dc axel cups
 sudo apt-get install cups-filters unp system-config-printer-gnome
 sudo rm -rf /usr/share/hplip
 cd /tmp
 rm foo*
 axel http://foo2zjs.rkkda.com/foo2zjs.tar.gz
 unp foo2zjs.tar.gz
 cd foo2zjs/
 make
./getweb P1006 # Get HP LaserJet P1006 firmware file
 sudo make install
 sudo make install-hotplug
 # Unplug and re-plug the USB printer into the PC
 # add new HP Laserjet 1020 printer via system-config-printer tool
 # and choose to use foo2zjs foomatic printer driver :
 system-config-printer
 # check /var/log/syslog for any errors related to foo2zjs driver:
 tail /var/log/syslog

Sources:

https://mark911.wordpress.com/2014/10/31/how-to-install-printer-drivers-for-hp-laserjet-1020-in-ubuntu-14-04-lts-without-needing-access-to-openprinting-org-website/

http://foo2zjs.rkkda.com/

http://foo2xqx.rkkda.com/

peter ratcliffe (pjcr) said : #3

Mark,
I opened a terminal and followed your script as far as CD/temp without problems. The result from rmfoo* brought up

peter@peter-desktop:~$ cd /tmp
peter@peter-desktop:/tmp$ rm foo*
rm: remove write-protected regular file 'foomatic-1RpstL'?
rm: remove write-protected regular file 'foomatic-LXUSBa'? axel http://foo2zjs.rkkda.com/foo2zjs.tar.gz
rm: remove write-protected regular file 'foomatic-vdnyME'? axel
peter@peter-desktop:/tmp$ unp foo2zjs.tar.gz
Cannot read foo2zjs.tar.gz, skipping...
WARNING: There were errors while processing files!
peter@peter-desktop:/tmp$

This doesn't look right so I wonder if I have missed anything. A second question comes at "add new HP laserjet 1020 printer". Should this be HPLaserjet P1102 which is my other printer - I don't have a 1020.

Peter Ratcliffe waiting your advise .

Best Manfred Hampl (m-hampl) said : #4

You missed the command

axel http://foo2zjs.rkkda.com/foo2zjs.tar.gz

Restart and continue the procedure at that step.

peter ratcliffe (pjcr) said : #5

Thanks Manfred Hampl, that solved my question.