I downlaoded a zip now what do i do with it

Asked by Bob on 2017-09-13

I downloaded this
https://github.com/coldfix/pidgin-tts

and now have pidgin-tts-master.zip in my download file. I've never used a zip that was a program or what ever this is called.

I've done zip that where mp.3 file and I just extract it and I have it. So this is completely new to me.

I thought I would try this because Pidgin stopped talking to me with the plugin Festival 2.4. some time ago. Another great thing lost to updates. There is no info out there on why or how to get it to work again that I could find and I really need to know what to do with a zip that is not just a mp'3 file hiding in it.

I tried what it said on the page but make && make install did nothing by itself. I did not think it would so I know I'm lacking info on what I need to do.
Step by step is what I need. I've read a few page about zip but they all read with the intent that I should know something about them.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2017-10-01
Last reply:
2017-10-02

What is the output of:

lsb_release -a; uname -a; apt-cache policy `dpkg -l | grep pidgin | awk ('print $2')`

Thanks

Bob (smith13) said : #2

This is strange Festival worked yesterday on Pidgin. But of corse it's not today. No clue why it worked or why it stoped again.

 lsb_release -a; uname -a; apt-cache policy `dpkg -l | grep pidgin | awk ('print $2')`
LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial
Linux hermann 4.4.0-93-generic #116-Ubuntu SMP Fri Aug 11 21:17:51 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
bash: command substitution: line 1: syntax error near unexpected token `'print $2''
bash: command substitution: line 1: `dpkg -l | grep pidgin | awk ('print $2')'
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://ppa.launchpad.net/qbittorrent-team/qbittorrent-stable/ubuntu xenial/main i386 Packages
     release v=16.04,o=LP-PPA-qbittorrent-team-qbittorrent-stable,a=xenial,n=xenial,l=qbittorrent-stable,c=main,b=i386
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/qbittorrent-team/qbittorrent-stable/ubuntu xenial/main amd64 Packages
     release v=16.04,o=LP-PPA-qbittorrent-team-qbittorrent-stable,a=xenial,n=xenial,l=qbittorrent-stable,c=main,b=amd64
     origin ppa.launchpad.net
 500 http://download.opensuse.org/repositories/home:/jgeboski/xUbuntu_16.04 Packages
     release o=obs://build.opensuse.org/home:jgeboski/xUbuntu_16.04,n=xUbuntu_16.04,l=home:jgeboski,c=
     origin download.opensuse.org
 500 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages
     release v=1.0,o=Google, Inc.,a=stable,n=stable,l=Google,c=main,b=amd64
     origin dl.google.com
 500 http://archive.canonical.com/ubuntu xenial/partner i386 Packages
     release v=16.04,o=Canonical,a=xenial,n=xenial,l=Partner archive,c=partner,b=i386
     origin archive.canonical.com
 500 http://archive.canonical.com/ubuntu xenial/partner amd64 Packages
     release v=16.04,o=Canonical,a=xenial,n=xenial,l=Partner archive,c=partner,b=amd64
     origin archive.canonical.com
 500 http://security.ubuntu.com/ubuntu xenial-security/multiverse i386 Packages
     release v=16.04,o=Ubuntu,a=xenial-security,n=xenial,l=Ubuntu,c=multiverse,b=i386
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 Packages
     release v=16.04,o=Ubuntu,a=xenial-security,n=xenial,l=Ubuntu,c=multiverse,b=amd64
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages
     release v=16.04,o=Ubuntu,a=xenial-security,n=xenial,l=Ubuntu,c=universe,b=i386
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages
     release v=16.04,o=Ubuntu,a=xenial-security,n=xenial,l=Ubuntu,c=universe,b=amd64
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu xenial-security/restricted i386 Packages
     release v=16.04,o=Ubuntu,a=xenial-security,n=xenial,l=Ubuntu,c=restricted,b=i386
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
     release v=16.04,o=Ubuntu,a=xenial-security,n=xenial,l=Ubuntu,c=restricted,b=amd64
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
     release v=16.04,o=Ubuntu,a=xenial-security,n=xenial,l=Ubuntu,c=main,b=i386
     origin security.ubuntu.com
 500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
     release v=16.04,o=Ubuntu,a=xenial-security,n=xenial,l=Ubuntu,c=main,b=amd64
     origin security.ubuntu.com
 100 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe i386 Packages
     release v=16.04,o=Ubuntu,a=xenial-backports,n=xenial,l=Ubuntu,c=universe,b=i386
     origin us.archive.ubuntu.com
 100 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 Packages
     release v=16.04,o=Ubuntu,a=xenial-backports,n=xenial,l=Ubuntu,c=universe,b=amd64
     origin us.archive.ubuntu.com
 100 http://us.archive.ubuntu.com/ubuntu xenial-backports/main i386 Packages
     release v=16.04,o=Ubuntu,a=xenial-backports,n=xenial,l=Ubuntu,c=main,b=i386
     origin us.archive.ubuntu.com
 100 http://us.archive.ubuntu.com/ubuntu xenial-backports/main amd64 Packages
     release v=16.04,o=Ubuntu,a=xenial-backports,n=xenial,l=Ubuntu,c=main,b=amd64
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse i386 Packages
     release v=16.04,o=Ubuntu,a=xenial-updates,n=xenial,l=Ubuntu,c=multiverse,b=i386
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 Packages
     release v=16.04,o=Ubuntu,a=xenial-updates,n=xenial,l=Ubuntu,c=multiverse,b=amd64
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages
     release v=16.04,o=Ubuntu,a=xenial-updates,n=xenial,l=Ubuntu,c=universe,b=i386
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
     release v=16.04,o=Ubuntu,a=xenial-updates,n=xenial,l=Ubuntu,c=universe,b=amd64
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted i386 Packages
     release v=16.04,o=Ubuntu,a=xenial-updates,n=xenial,l=Ubuntu,c=restricted,b=i386
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
     release v=16.04,o=Ubuntu,a=xenial-updates,n=xenial,l=Ubuntu,c=restricted,b=amd64
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
     release v=16.04,o=Ubuntu,a=xenial-updates,n=xenial,l=Ubuntu,c=main,b=i386
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     release v=16.04,o=Ubuntu,a=xenial-updates,n=xenial,l=Ubuntu,c=main,b=amd64
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial/multiverse i386 Packages
     release v=16.04,o=Ubuntu,a=xenial,n=xenial,l=Ubuntu,c=multiverse,b=i386
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages
     release v=16.04,o=Ubuntu,a=xenial,n=xenial,l=Ubuntu,c=multiverse,b=amd64
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
     release v=16.04,o=Ubuntu,a=xenial,n=xenial,l=Ubuntu,c=universe,b=i386
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
     release v=16.04,o=Ubuntu,a=xenial,n=xenial,l=Ubuntu,c=universe,b=amd64
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial/restricted i386 Packages
     release v=16.04,o=Ubuntu,a=xenial,n=xenial,l=Ubuntu,c=restricted,b=i386
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
     release v=16.04,o=Ubuntu,a=xenial,n=xenial,l=Ubuntu,c=restricted,b=amd64
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial/main i386 Packages
     release v=16.04,o=Ubuntu,a=xenial,n=xenial,l=Ubuntu,c=main,b=i386
     origin us.archive.ubuntu.com
 500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
     release v=16.04,o=Ubuntu,a=xenial,n=xenial,l=Ubuntu,c=main,b=amd64
     origin us.archive.ubuntu.com
Pinned packages:

What is the output of:

apt-cache policy pidgin

Thanks

Bob (smith13) said : #4

 apt-cache policy pidgin
pidgin:
  Installed: 1:2.10.12-0ubuntu5.2
  Candidate: 1:2.10.12-0ubuntu5.2
  Version table:
 *** 1:2.10.12-0ubuntu5.2 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages
        100 /var/lib/dpkg/status
     1:2.10.12-0ubuntu5 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

Bob (smith13) said : #5

I see on the first readout that some things read i386.
Is that not for a 32bit? I'm 64bit.
I was just wondering if this is what is getting in the way of letting Festival to work with pidgin.
Just a thought.

Possibly. Is there a 64bit version of the download?

Bob (smith13) said : #7

is xenial-backports pidgin? does it have anything to do with this? I don't know?

Manfred Hampl (m-hampl) said : #8

1.There was something wrong with actionparsnip's first command (probably a wrong ' instead of a `quote and/or round instead of curly braces).
2. Due to this the output shows the general package management settings (listing all activated sources) and no details about pidgin
3. It is correct to see i386, because you can also install 32bit packages on a 64bit system
4. If you look at https://launchpad.net/ubuntu/+source/pidgin you see that there is no version of pidgin in xenial-backports.

What you have to do with a zip file very much depends on what is inside this tarball. Usually you get some kind of instructions together with it.

Bob (smith13) said : #9

Read me file first step reads

Build and install the plugin with the commands

    make && make install

and I do and get

sudo make && make install
make: *** No targets specified and no makefile found. Stop.

I'm not doing something right and I don't know what it is. what is Targets?

After that it reads

This will compile the code and - in a second step - copy generated shared object to your `~/.purple/plugins/` directory.
Afterwards you have to enable the plugin in your Pidgin options.

ok I know where .purple/plugins is :)
I'm assuming that "copy generated shared object" is me moving the file I just extracted to that location? ? or is that going to be something elce??

I've always used the software center to install things so I'm running blind. lol

Here is the comple read me file just in case you need to see it all.

## pidgin-tts

### Description

This is a plugin for Pidgin-IM which can be used to automatically read incoming messages via an installed TTS (text-to-speech) application.

### Features

### Limitations

The program

* is tested on Linux only (and will probably not compile elsewhere)
* is designed for use with the `espeak` program. I don't know which other TTS applications it may support

### Installation

Build and install the plugin with the commands

    make && make install

This will compile the code and - in a second step - copy generated shared object to your `~/.purple/plugins/` directory.
Afterwards you have to enable the plugin in your Pidgin options.

Make sure to have the `espeak` utility installed on your system.

### Commands

The plugin is controlled from within the message window.
All commands are prefixed by `/tts`. For example

    /tts on
    /tts off

will globally turn the plugin on/off.
The `buddy on/off` commands allow to control only the current conversation.

The `status` command logs the current status into the conversation window.

You might also be interested in controlling the language and volume

    /tts volume 100
    /tts lang de

Note that the volume must be a number between 0 and 200.
You can find possible values for the language by typing `espeak --voices` in your shell.

Advanced configuration can be understood by looking at the source code.

Manfred Hampl (m-hampl) said : #10

"I've always used the software center to install things" - Yes, this is the recommended way to install software in Ubuntu.
But pidgin-tts seems not to be available as a package for installation with software center. So you have to compile it from source.

First step: downloading the source (already done).
Second step: unpacking the tarball (seems to be the missing step!)
Third step: compiling (fails for you because the second step was not done).

Bob (smith13) said : #11

Second step: unpacking the tarball (seems to be the missing step!)
So how do I do this or can it not be done with this file?

Manfred Hampl (m-hampl) said : #12

Can't you do a basic web search how to unpack a zip file?

http://lmgtfy.com/?q=ubuntu+unpack+zip+file

Bob (smith13) said : #13

Yes, I have but reading 5 page with 5 different instruction, what one is the right one?
So I tried them all to no avail. Should I try the next 5 and waste more time? Augh.

Do I have to start from the downloading? delete the file that is now in purple? I just don't know.

I still have no clue what is "copy generated shared object" what is a that? I think that's a big one I don't know.
I'm assuming it's the file I extracted? But have no clue. being the first time.

Do I not right click & extract it where it is? was that a mistake? I feel it maybe.

I have so many questions and no answers.
can you give me a link to how to do this the right way so I can learn. please....

I did find this page http://www.wikihow.com/Unzip-Files-in-Linux
but do I have to delete the file I already have sitting in purple? and start fresh??

sorry, I'm hitting you with a lot of question. But I'm clueless on this.

I have also spent time trying to find out why festival stopped working with pidgin. to no avail again. I just need the IM to read my messages to me. I don't care what or how. With failing eye site it was a blessing form the computer god "Linux" "open source" when it was speaking to me. Sorry, I'm venting but this is worse than losing the ability to drive a car. The zoom can only do so much but my ears are still working. lol I wish I was 10 years younger on the computer timeline. I would have this one down by now.

Give me some hints answers. I am trying. :)

Manfred Hampl (m-hampl) said : #14

Can't you put the pieces together?

1. Visit https://github.com/coldfix/pidgin-tts
2. Click on the green box "clone or download" and in the pop-up select "Download Zip".
3. Save the file pidgin-tts-master.zip in a suitable directory, e.g. your Downloads folder.
4. Open a terminal window
5. Create a work directory: "md src"
6. Change to that work directory: "cd src"
7. Unzip the tarball file that you have downloaded: "unzip ~/Downloads/pidgin-tts-master.zip" (adapt file and directory name if applicable)
8. Change to the directory with the software: "cd pidgin-tts-master"
9. Build and install the software with the instructions on the github pages: "make && make install"

Can you help with this problem?

Provide an answer of your own, or ask Bob for more information if necessary.

To post a message you must log in.