I click on on-line help, the system looks for Firefox 55, realizes Firefox ESR is running, doesn't use any of them.

Asked by Alberto on 2017-09-04

Hello Techies,
as my machine is very old and its CPU doesn't support SSE2 extension I had to install and use Firefox ESR. No problem so far, it works properly.
But when Firefox ESR is running and I click to get some app's on-line help (LibreWriter, Xboard...) a box appears:

'Firefox is already running but is not responding. To open a new window you must first close the existing Firefox process, or restart your system.'
Stop: no help...

This makes me think that the on-line help needs that particular Firefox (the non-ESR, I could call it the normal one) my system came with when I installed the O.S. months ago.

Is there a way to setup the system so that when I click on some on-line help pages it uses Firefox ESR?
Should I remove the (normal) Firefox in order to prevent this conflict? Because the (normal) Firefox is still installed- and updated- to my system. I feel a bit silly about this...
Many thanks and regard

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2017-09-11
Last query:
2017-09-11
Last reply:
2017-09-11

If you close all Firefox browsers then click the link does it work OK?

Alberto (alberto-aimo) said : #2

Hello Andrew,
if I close all Firefox browsers and then click the help link Firefox (55.0.2, the normal one) is launched and I can read the help page.

Alberto (alberto-aimo) said : #3

What am I supposed to do? Remove the (normal) Firefox? By the way I don't use it anymore...
Thanks

If you rename ~/.mozilla does it work OK?

Alberto (alberto-aimo) said : #5

Hello Andrew,
should I rename this folder?

/home/alberto/.mozilla

Which new name should I give?

Yes. That's the one. Just give it a different name. Something like

.mozilla_old

Manfred Hampl (m-hampl) said : #7

What programs have you set as the default applications in your system settings?

Alberto (alberto-aimo) said : #8

Hello Manfred,
can you please tell me where I can find the information you need?
I remember something about Ubuntu but now I run Lubuntu and I got lost!

Alberto (alberto-aimo) said : #9

Hello Andrew,
I've made the test you suggested. It doesn't work, I guess the system looks for the (normal) Firefox and outputs what I quoted in my question.
Thanks

If the folder doesn't exist then a vanilla one is created. It's also a fantastic way to back up your settings. Very simple.

What is the output of:

lsb_release -a; uname -a; apt-cache policy firefox

Thanks

Alberto (alberto-aimo) said : #11

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial

uname -a
Linux jalopy 4.10.0-33-generic #37~16.04.1-Ubuntu SMP Fri Aug 11 14:03:33 UTC 2017 i686 athlon i686 GNU/Linux

apt-cache policy firefox
firefox:
  Installed: 55.0.2+build1-0ubuntu0.16.04.1
  Candidate: 55.0.2+build1-0ubuntu0.16.04.1
  Version table:
 *** 55.0.2+build1-0ubuntu0.16.04.1 500
        500 http://it.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
        100 /var/lib/dpkg/status
     45.0.2+build1-0ubuntu1 500
        500 http://it.archive.ubuntu.com/ubuntu xenial/main i386 Packages

(I don't understand what you say about vanilla and backing up my settings...)

Best Manfred Hampl (m-hampl) said : #12

For the default programs:
I am not sure how this looks in Lubuntu, but in "normal" Ubuntu it is in "system settings - details"
https://www.howtogeek.com/117709/how-to-change-your-default-applications-on-ubuntu-4-ways/

Or maybe from command line
sudo update-alternatives –config gnome-www-browser
and/or
sudo update-alternatives –config x-www-browser

You should select firefox esr there (if that is possible).

Alberto (alberto-aimo) said : #13

Great, Manfred!
It's just what I needed.
I found these details in:
Preferences-->Deafault applications for LX session.
The box is called LS session configuration. It looks like Ubuntu's.

The problem is solved.

Alberto (alberto-aimo) said : #14

Thanks Manfred Hampl, that solved my question.