Ati radeon dual screen

Asked by Unetwork on 2007-05-14

I finally have dual screen with my ati radeon 9250 but now I would like to have the mouse at the right screen going.

When I want to go from my main screen LG to the Sony G500 (second screen) which is on the right side of the LG (main screen) I have to go with the mouse to the left this to exit the main screen and to enter the second screen.
Any suggestions to turn this around?
Thanks.

Here my xorg.conf:
==================================================================================================================

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
 FontPath "/usr/share/fonts/X11/misc"
 FontPath "/usr/share/fonts/X11/cyrillic"
 FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/Type1"
 FontPath "/usr/share/fonts/X11/100dpi"
 FontPath "/usr/share/fonts/X11/75dpi"
 # path to defoma fonts
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
 Load "i2c"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "vbe"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "us"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ImPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "stylus"
 Option "Device" "/dev/input/wacom"
 Option "Type" "stylus"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "eraser"
 Option "Device" "/dev/input/wacom"
 Option "Type" "eraser"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "cursor"
 Option "Device" "/dev/input/wacom"
 Option "Type" "cursor"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
    Identifier "ATI Technologies Inc RV280 [Radeon 9200 PRO] 0"
    VendorName "ATI"
    BoardName "ATI Radeon"
    Driver "radeon"
    BusID "PCI:1:0:0"
    Screen 0
EndSection

Section "Device"
    Identifier "ATI Technologies Inc RV280 [Radeon 9200 PRO] 1"
    BoardName "ATI Radeon"
    Driver "radeon"
    BusID "PCI:1:0:0"
    Screen 1
EndSection

Section "Monitor"
 Identifier "L194WT"
 Option "DPMS"
         HorizSync 56-70
         VertRefresh 28-83
EndSection

Section "Monitor"
 Identifier "CPD-G500"
 Option "DPMS"
        HorizSync 30-121
        VertRefresh 48-160
EndSection

Section "Screen"
 Identifier "Default Screen0"
 Device "ATI Technologies Inc RV280 [Radeon 9200 PRO] 0"
 Monitor "L194WT"
 DefaultDepth 24
 SubSection "Display"
  Depth 1
  Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 4
  Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 8
  Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 15
  Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 16
  Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 24
  Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
EndSection

Section "Screen"
Identifier "Default Screen1"
Device "ATI Technologies Inc RV280 [Radeon 9200 PRO] 1"
Monitor "CPD-G500"
DefaultDepth 24
      SubSection "Display"
            Depth 1
            Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
      EndSubSection
      SubSection "Display"
             Depth 4
             Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
     EndSubSection
     SubSection "Display"
            Depth 8
            Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
     EndSubSection
     SubSection "Display"
            Depth 15
            Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
            Depth 16
            Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
           Depth 24
           Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
  Identifier "Default Layout"
  Screen "Default Screen0"
  Screen "Default Screen1" LeftOf "Default Screen0"
  InputDevice "Generic Keyboard"
  InputDevice "Configured Mouse"
  InputDevice "stylus" "SendCoreEvents"
  InputDevice "cursor" "SendCoreEvents"
  InputDevice "eraser" "SendCoreEvents"
  Option "Xinerama" "on"
  Option "Clone" "on"
EndSection

Section "DRI"
 Mode 0666
EndSection

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Massimo Forti
Solved:
2007-05-14
Last query:
2007-05-14
Last reply:
2007-05-14
Best Massimo Forti (slackwarelife) said : #1

Hi, ok I understnd, you must change this lines of your
xorg.conf file:

FROM THIS:

Section "ServerLayout"
  Identifier "Default Layout"
  Screen "Default Screen0"
  Screen "Default Screen1" LeftOf "Default Screen0"
  InputDevice "Generic Keyboard"
  InputDevice "Configured Mouse"
  InputDevice "stylus" "SendCoreEvents"
  InputDevice "cursor" "SendCoreEvents"
  InputDevice "eraser" "SendCoreEvents"
  Option "Xinerama" "on"
  Option "Clone" "on"
EndSection

TO THIS:

Section "ServerLayout"
  Identifier "Default Layout"
  Screen "Default Screen0"
  Screen "Default Screen1" RightOf "Default Screen0"
  InputDevice "Generic Keyboard"
  InputDevice "Configured Mouse"
  InputDevice "stylus" "SendCoreEvents"
  InputDevice "cursor" "SendCoreEvents"
  InputDevice "eraser" "SendCoreEvents"
  Option "Xinerama" "on"
  Option "Clone" "on"
EndSection

Let me know. Before do this you must create your xorg.conf
backup file.

THANKS MANY

----- Segue Messaggio Originale -----
Da : Unetwork <email address hidden>
A : <email address hidden>
oggetto : [Question #6574]: Ati radeon dual screen
Data : Mon, 14 May 2007 10:16:17 -0000

> Question #6574 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/6574
>
> Summary changed to:
> Ati radeon dual screen

Unetwork (bosse-kvkmk) said : #2

Ok thanks I saw it and learned something :)

Unetwork (bosse-kvkmk) said : #3

Thanks Massimo Forti, that solved my question.

islseur (islseur) said : #4

Unetwork in the manual for the screen LG L194WT on LG site it says that the refresh specs are different!
http://www.lge.com/products/model/detail/L194WT.jhtml

In your xorg.conf file it's
Section "Monitor"
 Identifier "L194WT"
 Option "DPMS"
         HorizSync 56-70
         VertRefresh 28-83
EndSection

In the Manual the Figures are:
Horizontal Freq. Analog : 30 - 83 kHz (Automatic)
                 Digital : 30 - 83 kHz (Automatic)
Vertical Freq. 56 - 75 Hz (Automatic)

If you will not correct these figures your chip for the resolution will eventually be damaged and it will not boot the resolution. It happened to me on my samsung 710N screen in 1280x1024 in my xorg.conf on Vertical Freq it was 82 instead of 75 max and it eventually got fried.

Watch out for this thing.