Upgrade Failed Too Many Errors - save bookmarks

Asked by Tracy Cann on 2017-08-10

When I upgraded to 16.04, the upgrade stopped with the error message "too many errors". My computer now goes to a screen which I think is called a recovery mode screen(?). It has 16.04 at the top and has a log in prompt and I figured out that I can log in. But I don't know how to do much of anything else at this point.

I figured out how to save the directories and files I want to save. But I can't figure out how to save my bookmarks (I've got hundreds).

Mozilla support https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data says that the bookmarks are stored in a places.sqlite file. But it is in a hidden directory.

How do I access that hidden directory so that I can copy the bookmarks file to a flash drive?
Thanks,
Tracy

Oh and after I save my bookmarks file, I plan on reloading 16.04 from a cd which is why I've saved the directories and files and want to save my bookmarks.

Also, I need step by step "type this exactly then press enter" type instructions.

Question information

If your bookmarks are important, why don't you have a backup?
Why did you not make a full backup of all your important data before starting the process?

If you copy ~/.mozilla from the drive then you can restore settings easily. Just paste the folder in place one you get reinstalled.

Manfred Hampl (m-hampl) said : #4

How does this screen look like?
Just plain black-and-white or color?
All character-base with all characters having the same width?

There might still be some possibilities to bring your system back to normal function.

Tracy Cann (tracycann) said : #5

How do I copy the -/.mozilla directory?

Manfred the screen is a black background and white letters screen. After I log in it goes to this prompt
tracy@TCannHouse:>$ prompt. The greater than symbol is really a "hat" but I can't find that on the keyboard.

Tracy Cann (tracycann) said : #6

Just fount the ^ on my keyboard.

Tracy Cann (tracycann) said : #7

And its the ~ symbol, not the "hat". Didn't have my glasses on.

^ is called a carat
If you boot to live Ubuntu CD desktop then you can mount your internal partitions and copy the folder.

Remember to set nautilus (the file manager in Ubuntu) to show hidden files and folders

Obviously copy it to USB or upload to Dropbox etc. You could even zip it up and email it to yourself

Tracy Cann (tracycann) said : #10

I tried the live CD and copy it option. It didn't work. It said I didn't have permissions to access the directory. I think that using the live CD I'm not an Administrator and then I can't copy the hidden directory. Though I didn't try copying the entire directory. I'll try that now.

Run nautilus with sudo

Tracy Cann (tracycann) said : #12

Trying to copy the entire ,mozilla directory with the live CD doesn't work. I get a "do not have permissions" error message.

How do I "run nautilus with sudo"? From the live cd? Or from the tracy@TCannHouse:~$ prompt?

Tracy Cann (tracycann) said : #13

Manfred if you can help me to fix the errors then finish the upgrade, then that would be preferrable. I just noticed other files or directories that I didn't save. Plus my wife's bookmarks.

The top link above talks about doing this "moving the virtuoso-nepomuk script from /etc/init.d". But I don't know how. Another post mentions deleting "virtuoso-nepomuk".

Tracy Cann (tracycann) said : #14

Andrew, what about changing the properties of the .mozilla directory so that it isn't a hidden directory?

The leading period character marks it hidden

Tracy Cann (tracycann) said : #16

Here https://askubuntu.com/questions/813013/upgrade-from-14-04-to-16-04-failed-with-too-many-errors-then-the-sytem-failed-to

I found this.
" I also faced this issue and filed a bug in launchpad : https://bugs.launchpad.net/ubuntu/+source/sysvinit/+bug/1610241

My solution was the following :

    fix the /etc/init.d/virtuoso-nepomuk file by adding ### END INIT INFO at the end of the block started with ### BEGIN INIT INFO
    resume the upgrade process with sudo apt-get upgrade

In any case, it's a bug. I suggested a few ways to fix that on launchpad, but it's not done yet."

Using the text editor I found the file and attempted to edit it. But it opens as read only so I couldn't save the change.

I read in another post about using nano or vi to edit files in Terminal. If I am at the tracy@TCannHouse:~$ prompt, can I run Terminal from there?

Or how do I change directory to that directory and then edit the file?

Tracy Cann (tracycann) said : #17

From this prompt
tracy@TCannHouse:~$
I entered sudo edit\ /etc/init.d/virtuoso-nepomuk

It seems to open the file. But when I move down to the line that needs "END INIT INFO" the cursor won't move into position so that I can enter the needed text.

Then how do I save the file?

If you run:

 sudo gedit /etc/init.d/virtuoso-nepomuk

You can edit the file. If you are in a terminal then use:

sudo nano /etc/init.d/virtuoso-nepomuk

Use CTRL + X to exit and hit ENTER to accept the same filename

Tracy Cann (tracycann) said : #19

The laptop I'm using doesn't have the virtuoso-nepomuk file in the directory. So I used

sudo rm /etc/init.d/virtuoso-nepomuk

to delete the file. Then I used

sudo apt-get upgrade

to finish installing the upgrade. When it rebooted some error messages appeared. But it's back in a GUI working form.

And yes I will back up my bookmarks next time.