USB Mic Not Resuming Ubuntu 16.04

Asked by Rhett Aultman on 2017-08-10

I've got a Logitech BRIO USB webcam (046d:085e) that mostly works wonderfully with my Ubuntu 16.04 desktop. Unfortunately, it's having some issues with the system suspend/resume that I don't know how to troubleshoot further.

Symptom:
On resume, the USB microphone interfaces appear in the "Input" tab of the Sound Settings, but it can't record audio from it and thus the volume meters don't move. Using the mic in Audacity causes it to hang.

What I do know and what I've already tried:
The interfaces appear in an "arecord -l", but they just seem to...do nothing. The device itself does appear in an lsusb, and all its interfaces appear present. I have tried an unbind/rebind on the driver. I've tried setting its "authorized" from 1 to 0 and back again. These sorts of "soft restart" of the device have not resolved the problem. I can confirm I'm doing them correctly because I see the interfaces disappear and reappear from an "arecord -l". Recording with arecord on the device produces a file full of 0s. I guess this means Audacity is stalling on something other than a read from the mic.

Only known workaround:
Unplugging and replugging the camera resolves the issue. Everything then works as expected...until the next suspend/resume.

What I'm hoping to find:
At a minimum, something that does a real, serious, just-like-i-unplugged-it reset of the device. Maybe then I'd be able to make a restart script to fix it. Failing that, I'd love to at least know more about this issue so that I can help resolve it. I'm a reasonably competent low-level software engineer, but I don't know as much about USB power management (i.e. suspend/resume) as I ought to.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2017-08-10
Last reply:
2017-08-26

Afer you un-suspend, if you run:

killall pulseaudio

then wait 10 seconds, is it OK?

Rhett Aultman (roadriverrail) said : #2

It didn't appear to help, sorry. I should also mention that I tried "pulseaudio -k" and that didn't seem to help either.

Rhett Aultman (roadriverrail) said : #3

Did anyone have any more insights? My mic is part of an automated voice response unit, so having it work regularly is pretty important to me, and I'd love to find out how to get to the bottom of this issue.

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Open' state without activity for the last 15 days.