A failed install & failed unistall has left me with seriouos errors

Asked by Jeff H. on 2017-08-08

I tried to install VyprVPN 0.0.1.55 using Synaptics package manager like VyprVPN suggests. The install failed and told me to uninstall it. After I did I now have this warning at the top of my screen.

Unknown Error: class> 'SystemError'> E:The package needs to be reinstalled, but I can't find an archive for it.) This usually means that your installed packages have unmet dependencies.

Also, now when I try to use Synaptics, wget or GDebi they all return a similar error message and then close/crash upon acknowledgement of the error message. Preventing me from installing other packages or receiving updates.

I need serious help in solving this as my CLI is rusty as hell since I haven't really used it since Winsows 3 and 3.1 where just fancy GUI that worked by CLI.

Thanks in advance for your time and patience.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Jeff H.
Solved:
2017-08-08
Last query:
2017-08-08
Last reply:
2017-08-08

What is the output of:

sudo apt-get -f install; lsb_release -a; uname -a

Thanks

Jeff H. (desertgunr) said : #2

Here it is:

sudo apt-get -f install; lsb_release -a; uname -a
[sudo] password for jeff:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: The package vyprvpn needs to be reinstalled, but I can't find an archive for it.
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial
Linux jeff-HP-Pavilion-dv3500-Notebook-PC 4.10.0-30-generic #34~16.04.1-Ubuntu SMP Wed Aug 2 02:13:56 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Manfred Hampl (m-hampl) said : #3

Apparently something went wrong with the uninstallation of the vyprvpn package.
You should try installing it again and then attempt a complete removal again (with package management programs).

Do you have the vyprvpn package still somewhere on your computer?

Executing the commands

sudo updatedb
locate vyprvpn

should help locating the file (if it is still present).

Jeff H. (desertgunr) said : #4

I agree something went terribly wrong with both the install & uninstall.
However, I can not do any installation of any packages vyprvpn or otherwise. Three different installers return error messages about the broken, malformed, or whatever you want to describe it as, package. When I try to get any updates, even from Ubuntu the Synaptic manager produces an error message, similar to the one I first posted. Once I acknowledge that error message Synaptic, wget & GDebi all immediately close/crash.

Here are the results of the last CLI command:

$ locate vyprvpn
/etc/vyprvpn
/etc/init/vyprvpn.conf
/etc/init.d/vyprvpn
/etc/vyprvpn/ca.vyprvpn.com.crt
/etc/vyprvpn/templates
/etc/vyprvpn/templates/chameleon.tmpl
/etc/vyprvpn/templates/openvpn.tmpl
/etc/vyprvpn/templates/openvpn256.tmpl
/etc/vyprvpn/templates/pptp.tmpl
/home/jeff/vyprvpn-linux-cli-1.7.amd64.deb
/home/jeff/.cache/upstart/update-notifier-crash-_var_crash_vyprvpn.0.crash.log.1.gz
/home/jeff/.cache/upstart/update-notifier-crash-_var_crash_vyprvpn.0.crash.log.2.gz
/home/jeff/.cache/upstart/update-notifier-crash-_var_crash_vyprvpn.0.crash.log.3.gz
/home/jeff/.cache/upstart/update-notifier-crash-_var_crash_vyprvpn.0.crash.log.4.gz
/home/jeff/.cache/upstart/update-notifier-crash-_var_crash_vyprvpn.0.crash.log.5.gz
/home/jeff/.cache/upstart/update-notifier-crash-_var_crash_vyprvpn.0.crash.log.6.gz
/home/jeff/.cache/upstart/update-notifier-crash-_var_crash_vyprvpn.0.crash.log.7.gz
/home/jeff/Downloads/vyprvpn-linux-cli-0.0.1-55.amd64.deb
/usr/bin/vyprvpn
/usr/sbin/vyprvpn_chameleon
/usr/sbin/vyprvpn_chameleon.sh
/usr/sbin/vyprvpn_service
/usr/share/vyprvpn
/usr/share/vyprvpn/readme.md
/var/lib/dpkg/info/vyprvpn.list
/var/lib/dpkg/info/vyprvpn.md5sums
/var/lib/dpkg/info/vyprvpn.postinst
/var/lib/dpkg/info/vyprvpn.prerm
/var/lib/dpkg.backup/info/vyprvpn.list
/var/lib/dpkg.backup/info/vyprvpn.md5sums
/var/lib/dpkg.backup/info/vyprvpn.postinst
/var/lib/dpkg.backup/info/vyprvpn.prerm

What is the output of:

sudo dpkg -i /home/jeff/vyprvpn-linux-cli-1.7.amd64.deb

Thanks

Jeff H. (desertgunr) said : #6

Here is the return as requested:

sudo dpkg -i /home/jeff/vyprvpn-linux-cli-1.7.amd64.deb
[sudo] password for jeff:
Selecting previously unselected package vyprvpn.
(Reading database ... 422340 files and directories currently installed.)
Preparing to unpack .../vyprvpn-linux-cli-1.7.amd64.deb ...
stop: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
dpkg: warning: subprocess old pre-removal script returned error exit status 1
dpkg: trying script from the new package instead ...
Failed to stop vyprvpn.service: Unit vyprvpn.service not loaded.
dpkg: ... it looks like that went OK
Unpacking vyprvpn (1.7) over (0.0.1-55) ...
Setting up vyprvpn (1.7) ...
Synchronizing state of vyprvpn.service with SysV init with /lib/systemd/systemd-sysv-install...
Executing /lib/systemd/systemd-sysv-install enable vyprvpn
Processing triggers for ureadahead (0.100.0-19) ...
ureadahead will be reprofiled on next reboot
Processing triggers for systemd (229-4ubuntu19) ...

Manfred Hampl (m-hampl) said : #7

The package management system seems to be back in a consistent state, installation and uninstallation of packages should work again.

The question now is: do you need the vyprvpn package installed?

Jeff H. (desertgunr) said : #8

The package management system just received a notification of updates and rebooted. Glad to have that working again.

As for VyprVPN, unfortunately I do need it for reasons that I'd rather not completely discuss openly. Let's just say I have several security threats in my life that make the need for extremely tight security needed. I pay for the service on my windows machines and I was hoping to use on my new Linux builds as well, especially since those are laptops.

Jeff H. (desertgunr) said : #9

Thanks for your help guys, much appreciated.

Manfred Hampl (m-hampl) said : #10

The VyprVPN package is already installed, so you might try whether it works.
(My question was more the other way round. If you do not need it, then we would have tried helping you do uninstall it again.)

Jeff H. (desertgunr) said : #11

Thanks, I noticed a 1.7 version had been added to my files folder as opposed to the 0.0.1.55 version on the Golden Frog site. The newer version installed without a problem and seems to be working now as does synaptic, wget & GDebi.

Great to know there is still good help to be had out there for those of us not so proficient at CLI & debugging.