Ubuntu 16.xx does not properly support GRASS GIS 7.xx

Asked by Ed Parnell on 2017-08-03

Hi forum, I have been using GRASS GIS in Ubuntu for years. Last year I upgraded to 16.04 and was not able to use GRASS 7.x, getting the message in the terminal: "Error - Debug: Failed to connect to session manager: SESSION_MANAGER environment variable not defined". GRASS runs, the GUI's open, but the functionality is limited. I cannot profile surface rasters, cannot set computational areas from the map GUI, etc... So I downgraded back to 14.04 and GRASS 6.4.xx figuring that this problem would be addressed in future Ubuntu updates/upgrades (but 14.04 support is not forever so I'm concerned that I might have to switch to another OS). This is likely a python issue and I've seen scattered reports of other people encountering the same issue with no solutions on the horizon. Every once in awhile I try on a completely separate computer to run GRASS 7.x in Ubuntu 16.04 and this has not yet been fixed - including just last week. Does anyone know if this issue is something that might be resolved in future updates/upgrades?

Thanks, Ed

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2017-08-03
Last reply:
2017-08-19

I suggest you also post on a GRASS forum as well. It's closer to your issue

Launchpad Janitor (janitor) said : #2

This question was expired because it remained in the 'Open' state without activity for the last 15 days.