Ubuntu 16.04 won't start after update

Asked by Ryan on 2017-08-03

I dual boot Windows 10 and Ubuntu 16.04.2 LTS on a Dell XPS15. I updated Ubuntu 16.04 last night and now it won't start. After updating, I shut it down. When I turned it back on I got the normal load screen with the word "ubuntu" and the 4 dots that change color, but after the 4th dot changed it got stuck and wouldn't load the login screen (I left it for several hours). Further attempts to start Ubuntu 16.04 gave similar results. I was wondering if anyone else has had a similar issue and if they had any suggestions. My data is backedup so it's not the end of the world if I have to reinstall Ubuntu.

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Ryan
Solved:
2017-08-11
Last query:
2017-08-11
Last reply:
2017-08-05
Bashing-om (bashing-om) said : #1

Ryan ; Hello:

Can you boot a recovery kernel ?
grub boot menu -> spam the escape key as the system boots
grub boot menu -> advanced options -> recovery kernel

We need to get to a terminal to investigate what is not going on.

-a terminal case-

Ryan (carrotsticks) said : #2

Yes I can boot a recovery kernel and from there I can continue loading Ubuntu and login. So loading Ubuntu from the recovery kernel works.

Bashing-om (bashing-om) said : #3

Ryan; Well, all to the good .

In that recovery console :
terminal command
lshw -C display

Is the display "unclaimed" ?
and what shows in the configuration line for a driver ?
as a reference mine:
"configuration: driver=nvidia latency=0"

where I am looking at this as a broken graphic's driver issue.
Fixable !

-all in the process-

Ryan (carrotsticks) said : #4

Yes, this does seem like a graphics driver issue. The display is listed as "unclaimed" and the configuration line says "latency=0". In addition if I look at the system details my graphics card is listed as "Gallium 0.4 on llvmpipe (LLVM 4.0, 256 bits)". For Ubuntu I'm using the integrated Intel graphics card, which is normally listed in the system details.

Thanks!
Ryan

Bashing-om (bashing-om) said : #5

Ryan; Yeah;

unclaimed display certainly indicates no driver is loaded for graphics.
So what is the hardware we are working with ?
post back the result of terminal command:
lspci -k|grep -iEA5 'vga|3d'

See then what driver should be installed, and then perhaps look at logs and see why the driver ( if it is Intel) did not install.

-we can do that-

Ryan (carrotsticks) said : #6

Okay problem solved. The integrated graphics card is Intel HD gaphics 630 and I also have a Nvidia GTX 1050. So how I understand it (correct me if I'm wrong) Ubuntu comes with the Intel drivers, so by default Ubuntu used the integrated Intel graphics. I tried for a while to find and install the correct Nvidia driver, but never had success.

After booting the recovery kernel and checking System settings> Software and updates> Additional Drivers the driver for my Nvidia card was listed. I just switched to that and now Ubuntu boots normally. So I guess with the last update Ubuntu added the Nvidia driver.

Thanks for all the help!