UEFI Keys not present after rebuilding/reloading kernel

Asked by Peter P. on 2017-08-02

I have a Ubuntu 17.04 system with SecureBoot enabled and have been rebuilding the kernel per the instructions found here:
https://wiki.ubuntu.com/Kernel/BuildYourOwnKernel

On a fresh install from a Ubuntu install ISO, I can see the keys pulled from UEFI when I run cat /proc/keys as root. However, when I rebuild and reload the kernel without any configuration modifications or code modifications., I no longer see any of the UEFI keys when I run cat /proc/keys and instead only see a build time autogenerated kernel key.

Is there a kernel configuration parameter or option I need to set in order to pull keys from UEFI instead of the autogenerated kernel key?

Thank you

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Peter P.
Solved:
2017-08-07
Last query:
2017-08-07
Last reply:
Peter P. (pp48711) said : #1

I found this issue was caused by not signing my kernel with my kernel signing key; this caused it to boot in legacy BIOS mode which is why no UEFI keys were shown in /proc/keys.