Support for ZTE ADSL modem

Asked by undog on 2007-05-13

ZxDSL 852 is a ADSL usb modem from ZTE. I got it to work on ubuntu 6.06, 6.10, 7.04 but I had to compile separate drivers: http://ftp.linux.it/pub/People/md/warez/cxacru-fw.bin.gz. I followed the instructions on http://doc.ubuntu-fr.org/materiel/zxdsl852 and have built the drivers. The problem is that I have to create the bridge every time I reboot and must configure the pppoe connection using pppoeconf. Could the cxacru be included in the next distribution of Ubuntu with a bugfix so you don't have to reconfigure the connection at every reboot? These ADSL modems are very popular in my country (Roumania) so I would be gratefull for help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Massimo Forti
Solved:
2007-05-16
Last query:
2007-05-16
Last reply:
2007-05-16
Massimo Forti (slackwarelife) said : #1

thanks for your question. But the how-to you have posted, it reports very well haw you can configure you pppoa connection using the right files of Ubuntu. What do you do to enable the connection with your ISP. Thanks

undog (victorsavu3) said : #2

The ISP dose not offer pppoa connection. My problem remains with pppoe.

Massimo Forti (slackwarelife) said : #3

Sorry for my delay. I understnad your problem, but there is not connection from the module which manager your modem and the ppoeconf which is the procedure to use for setting the modem like yours. Probably we can found a gui solution (but I don't know any) to simplify the configuration, but the pppoeconf is the tool used in linux to connect it on the ethernet protocol.

Thanks many

undog (victorsavu3) said : #4

I tried starting my connection at start-up by adding this script in init.d

br2684ctl -b -c 0 -e 0 -a 0.35
ifconfig nas0 up
pppd call zxdsl

but it needs sudo acces. How can I make the script to start with superuser acces?

Best Massimo Forti (slackwarelife) said : #5

Ok, it's a right way. I didn't think about this way. Good idea.
You can put your script in rc.local to be able to run it with root access at startup.

Thanks

undog (victorsavu3) said : #6

Thanks Massimo Forti, that solved my question.

undog (victorsavu3) said : #7

For any other user having this problem :
Add these three lines to your /etc/rc.local file, bofore the exit line :

br2684ctl -b -c 0 -e 0 -a 0.35
ifconfig nas0 up
pppd call zxdsl

This launches the connetcion at boot time.

Dhammika Pieris (mdp-kln) said : #8

My ZTE ADSL modem is not identified by the ubuntu system, so that i cannot continue the modem installaton.How can i solve this problem. How can i get theat /etc/rc. local file.