Ubuntu live cd 8.10 i386 will not boot to desktop.

Asked by ziggy1194 on 2009-03-21

The live cd stopped at:

 init: rc- default main process( 5304) terminated with status 255

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Craig Huffstetler
Solved:
Last query:
Last reply:
Best Craig Huffstetler (xq) said : #1

You have a few options here, as it has been a reported bug time and time again.

1) The less drastic is to attempt to boot using the alternative install CD. You can find the Alternate Install CD Images here to download:
http://www.ubuntu.com/getubuntu/downloadmirrors#alternate
I hope this will fix your issue, it sometimes does.

2) Attempt to disable PCI Express configurations in your BIOS before installation. You can re-enable them after installation.

Upon booting, go into your BIOS (usually by pressing F2 or another key or key combination on the initial boot screen). Then go into Chipset Configuration > PCI Express Configuration and change "Compliance Test" from <Enabled> to <Disabled>.

Some of the language may be different from manufacturer to manufacter; however, the concept is still the same: you need to disable PCI Express in BIOS.

3) It may be your video card (NVidia, most likely) causing a boot issue. You can remove your video card prior to booting before booting up and this will most likely correct the issue.
Check out bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/229753 for more details.

I hope this helps.

Regards,

Craig H.

Craig Huffstetler (xq) said : #2

Before we continue, and if the above does not work for you, can you confirm your hardware setup and what version of Ubuntu you are trying to install?

What kind of P.C. do you have?
What video card?
Sound card?
What version of Ubuntu are you trying to install?

Thank you for your time and patience.

Best regards,

Craig H.

P.S. - I did want to provide you with some links to some people with similar problems in the meantime for your reading:

https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/229753 (bug referenced above)
http://www.linux-noob.com/forums/index.php?s=a26e6eb42c8816459f002e76c6089826&showtopic=3051&pid=13000&st=0&#entry13000
http://www.linuxquestions.org/questions/linux-newbie-8/computer-hangs-when-trying-to-run-ubuntu-from-the-live-cd-686008/

Tom (tom6) said : #3

Wow, nice one Craig (or is it Chris? lol)

i think the first question is - why do you want to use the Ubuntu Cd as a Live Cd?

If it's to install Ubuntu or to just have a look at what it's like then Craig's advice is great. If you just happened to have the disc and found it didn't work so wanted to post a bug-report then don't worry. It's done already, thanks for helping us improve :) If you just need a quick desktop gui with Office apps, web-browser, wiifi and/or gparted then perhaps try Wolvix Hunter from
http://distrowatch.com/table.php?distribution=wolvix
or perhaps some other tiny distro might be worth exploring instead. Every distro has some configurations of hardware they don't work on "straight out of the box". In the Windows world the techs deal with all the installation issues before you see the machine. We tend to have to diy

Regards and good luck from
Tom :)

Craig Huffstetler (xq) said : #4

Tom,

It's Craig. Why would you think it's Chris? I thought I called myself this because I was talking to a Chris in real life when signing the last post. Either you have psychic abilities or are insane. But you should know I'm Craig by now ;-)

Cheers,

Craig

ziggy1194 (ziggy1194) said : #5

Thanks Craig Huffstetler, that solved my question.

ziggy1194 (ziggy1194) said : #6

I disabled pci express in the BIOS. Now my live cd works.

 Thank you very much.

Tom (tom6) said : #7

Brilliant, nicely done :)