b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found -> BCM4311 802.11b/g WLAN [14e4:4311] (rev 01) not working in Ubuntu 8.10

Asked by joshuatwise on 2009-03-18

I have a Dell Inspiron 1521 dualing Ubuntu and Vista. I have wireless support on Vista, and I can access the Internet via ethernet on Ubuntu, but I just can not get the wireless to work it. I installed Wine, and it almost got my original driver to work, but Ubuntu was not supported by the driver. What should I do?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
joshuatwise
Solved:
2009-03-18
Last query:
2009-03-18
Last reply:
2009-03-18

Hi,

Please first connect your network card to the wireless router using a LAN cable.

Then please follow this procedure (in order to gather troubleshooting info):

Step 1: Open Terminal from "Applications->Accessories->
Terminal"

Step 2: Run the following commands (copy-paste each line below to the Terminal then hit <enter> after each line)

sudo aptitude install hwinfo
hwinfo --netcard
sudo iwlist scanning
sudo lshw -C network
lspci -nn
lsusb
uname -a
dmesg | grep ound
dmesg | grep witch
iwconfig

Step 3: Please post results (copy/paste terminal output from each command) on this thread

Regards,

Mark

joshuatwise (joshuathomaswise) said : #2

joshua@ubuntu:~$ sudo aptitude install hwinfo
[sudo] password for joshua:
E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
Reading package lists... Done
Building dependency tree
Reading state information... Done
Initializing package states... Done
E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

joshua@ubuntu:~$ hwinfo --netcard
The program 'hwinfo' is currently not installed. You can install it by typing:
sudo apt-get install hwinfo
bash: hwinfo: command not found

joshua@ubuntu:~$ sudo iwlist scanning
[sudo] password for joshua:
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 Interface doesn't support scanning : Network is down

pan0 Interface doesn't support scanning.

joshua@ubuntu:~$ sudo lshw -C network
  *-network
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:0b:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0 module=ssb
  *-network
       description: Ethernet interface
       product: BCM4401-B0 100Base-TX
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 02
       serial: 00:1c:23:ab:c8:60
       size: 100MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=b44 driverversion=2.0 duplex=full ip=192.168.1.69 latency=64 link=yes module=ssb multicast=yes port=twisted pair speed=100MB/s
  *-network:0 DISABLED
       description: Wireless interface
       physical id: 2
       logical name: wlan0
       serial: 00:1d:60:d3:4b:d0
       capabilities: ethernet physical wireless
       configuration: broadcast=yes multicast=yes wireless=IEEE 802.11bg
  *-network:1 DISABLED
       description: Ethernet interface
       physical id: 3
       logical name: pan0
       serial: c2:b0:07:9c:03:69
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes

joshua@ubuntu:~$ lspci -nn
00:00.0 Host bridge [0600]: ATI Technologies Inc RS690 Host Bridge [1002:7910]
00:01.0 PCI bridge [0604]: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx) [1002:7912]
00:05.0 PCI bridge [0604]: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 1) [1002:7915]
00:07.0 PCI bridge [0604]: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 3) [1002:7917]
00:12.0 SATA controller [0106]: ATI Technologies Inc SB600 Non-Raid-5 SATA [1002:4380]
00:13.0 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI0) [1002:4387]
00:13.1 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI1) [1002:4388]
00:13.2 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI2) [1002:4389]
00:13.3 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI3) [1002:438a]
00:13.4 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI4) [1002:438b]
00:13.5 USB Controller [0c03]: ATI Technologies Inc SB600 USB Controller (EHCI) [1002:4386]
00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 14)
00:14.1 IDE interface [0101]: ATI Technologies Inc SB600 IDE [1002:438c]
00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]
00:14.3 ISA bridge [0601]: ATI Technologies Inc SB600 PCI to LPC Bridge [1002:438d]
00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384]
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS690M [Radeon X1200 Series] [1002:791f]
03:00.0 Ethernet controller [0200]: Broadcom Corporation BCM4401-B0 100Base-TX [14e4:170c] (rev 02)
03:01.0 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832] (rev 05)
03:01.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 22)
03:01.2 System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter [1180:0592] (rev 12)
03:01.3 System peripheral [0880]: Ricoh Co Ltd xD-Picture Card Controller [1180:0852] (rev 12)
0b:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)

joshua@ubuntu:~$ lsusb
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

joshua@ubuntu:~$ uname -a
Linux ubuntu 2.6.27-7-generic #1 SMP Fri Oct 24 06:42:44 UTC 2008 i686 GNU/Linux

joshua@ubuntu:~$ dmesg | grep ound
[ 0.708798] pnp: PnP ACPI: found 12 devices
[ 1.601211] pcieport-driver 0000:00:05.0: found MSI capability
[ 1.601405] pcieport-driver 0000:00:07.0: found MSI capability
[ 1.958381] isapnp: No Plug & Play device found
[ 2.018689] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 2.753296] No dock devices found.
[ 2.788122] ssb: Sonics Silicon Backplane found on PCI device 0000:0b:00.0
[ 2.848221] hub 1-0:1.0: USB hub found
[ 3.012279] hub 2-0:1.0: USB hub found
[ 3.173236] hub 3-0:1.0: USB hub found
[ 3.337489] hub 4-0:1.0: USB hub found
[ 3.500170] hub 5-0:1.0: USB hub found
[ 5.316256] hub 6-0:1.0: USB hub found
[ 5.488122] ssb: Sonics Silicon Backplane found on PCI device 0000:03:00.0
[ 12.901246] b43-phy0: Broadcom 4311 WLAN found
[ 13.429681] sdhci-pci 0000:03:01.1: SDHCI controller found [1180:0822] (rev 22)
[ 15.366583] lp: driver loaded but no devices found
[ 37.054196] powernow-k8: Found 1 AMD Athlon(tm) 64 X2 Dual-Core Processor TK-55 processors (2 cpu cores) (version 2.20.00)
[ 37.837590] apm: BIOS not found.
[ 42.034498] mtrr: base(0xe0000000) is not aligned on a size(0xc000000) boundary
[ 44.905446] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
[ 45.061349] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
[ 118.562056] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found

joshua@ubuntu:~$ dmesg | grep ound
[ 0.708798] pnp: PnP ACPI: found 12 devices
[ 1.601211] pcieport-driver 0000:00:05.0: found MSI capability
[ 1.601405] pcieport-driver 0000:00:07.0: found MSI capability
[ 1.958381] isapnp: No Plug & Play device found
[ 2.018689] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 2.753296] No dock devices found.
[ 2.788122] ssb: Sonics Silicon Backplane found on PCI device 0000:0b:00.0
[ 2.848221] hub 1-0:1.0: USB hub found
[ 3.012279] hub 2-0:1.0: USB hub found
[ 3.173236] hub 3-0:1.0: USB hub found
[ 3.337489] hub 4-0:1.0: USB hub found
[ 3.500170] hub 5-0:1.0: USB hub found
[ 5.316256] hub 6-0:1.0: USB hub found
[ 5.488122] ssb: Sonics Silicon Backplane found on PCI device 0000:03:00.0
[ 12.901246] b43-phy0: Broadcom 4311 WLAN found
[ 13.429681] sdhci-pci 0000:03:01.1: SDHCI controller found [1180:0822] (rev 22)
[ 15.366583] lp: driver loaded but no devices found
[ 37.054196] powernow-k8: Found 1 AMD Athlon(tm) 64 X2 Dual-Core Processor TK-55 processors (2 cpu cores) (version 2.20.00)
[ 37.837590] apm: BIOS not found.
[ 42.034498] mtrr: base(0xe0000000) is not aligned on a size(0xc000000) boundary
[ 44.905446] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
[ 45.061349] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
[ 118.562056] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found

joshua@ubuntu:~$ dmesg | grep witch
[ 0.544295] groups:<6>Switch to broadcast mode on CPU1
[ 0.544400] Switch to broadcast mode on CPU0
[ 0.724057] Switched to high resolution mode on CPU 0
[ 0.724068] Switched to high resolution mode on CPU 1
[ 11.818073] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input2
[ 11.818624] ACPI: Lid Switch [LID]

joshua@ubuntu:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:""
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          Tx-Power=0 dBm
          Retry min limit:7 RTS thr:off Fragment thr=2352 B
          Power Management:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

I tried. I'm sorry if I did anything wrong. Let me know, and I'll try to fix it.
Thanks.

Hi,

Your wireless issue is identical to this one:

https://answers.launchpad.net/ubuntu/+question/56393

I think you are experiencing this bug:

https://bugs.launchpad.net/ubuntu/+source/b43-fwcutter/+bug/197819

Please try this workaround solution:

https://bugs.launchpad.net/ubuntu/+source/b43-fwcutter/+bug/197819/comments/58

b43-fwcutter exists in the Ubuntu repositories, but you will need a working Internet connection in Ubuntu in order to install it.

The only way to do that - in your case - is to connect the pc to the wireless router using a LAN cable, instead of using wireless.

Regards,

Mark

joshuatwise (joshuathomaswise) said : #4

I'm sorry I made you go through this.
My Ubuntu updated while I was connected and it found new drivers that now work for it.
I didn't have to do anything.