Ubuntu Graphical mode not able to switch to Virtual Terminal

Asked by Yovan ZJW on 2017-06-15

My Laptop is running Ubuntu 16.04 Desktop. I am trying to switch to a Virtual Terminal (TTY1) from my common graphical session (TTY7).

However, the virtual Terminal did not show login prompt. After scouring the internet for solution, the available approach to manage the situation such as changing the grub command -line is not feasible and seems to sacrifice either the Graphical Mode or the Virtual Terminal.

I look forward to your advice.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Yovan ZJW
Solved:
2017-06-19
Last query:
2017-06-19
Last reply:
2017-06-17
Yovan ZJW (jiabanster) said : #1

glxinfo | grep 'opengl renderer' shows:

OpenGL renderer string: Mesa DRI Mobile IntelĀ® GM45 Express Chipset

xrandr --listproviders shows:

 Providers: number : 3
Provider 0: id: 0x6b cap: 0x9, Source Output, Sink Offload crtcs: 3 outputs: 4 associated providers: 2 name:Intel
Provider 1: id: 0x44 cap: 0x6, Sink Output, Source Offload crtcs: 2 outputs: 3 associated providers: 2 name:ATI Mobility Radeon HD 3400 Series @ pci:0000:01:00.0
Provider 2: id: 0x44 cap: 0x6, Sink Output, Source Offload crtcs: 2 outputs: 3 associated providers: 2 name:ATI Mobility Radeon HD 3400 Series @ pci:0000:01:00.0

lsmod | grep radeon shows:
radeon 1515520 1
ttm 94208 1 radeon
i2c_algo_bit 16384 2 i915,radeon
drm_kms_helper 155648 2 i915,radeon
drm 364544 8 ttm,i915,drm_kms_helper,radeon

lsmod | grep i915 shows:
i915 1208320 3
i2c_algo_bit 16384 2 i915,radeon
drm_kms_helper 155648 2 i915,radeon
video 40960 3 i915,toshiba_acpi,thinkpad_acpi
drm 364544 8 ttm,i915,drm_kms_helper,radeon

Should i blacklist either Radeon or i915 ? Any precaution to take before doing so?

Yovan ZJW (jiabanster) said : #2

Running

sudo grep -i switcheroo /boot/config-*

shows:

/boot/config-4.4.0-78-generic:CONFIG_VGA_SWITCHEROO=y
/boot/config-4.4.0-79-generic:CONFIG_VGA_SWITCHEROO=y

Running sudo lshw -C video shows:

*-display
       description: VGA compatible controller
       product: RV620/M82 [Mobility Radeon HD 3450/3470]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:31 memory:c0000000-cfffffff ioport:2000(size=256) memory:bfff0000-bfffffff memory:bff00000-bff1ffff
  *-display
       description: Display controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:29 memory:fc000000-fc3fffff memory:d0000000-dfffffff ioport:1800(size=8)

Manfred Hampl (m-hampl) said : #3

Are the getty processes correctly running?
What is the output of
ps ax | grep getty

Yovan ZJW (jiabanster) said : #4

Below is the output of ps ax | grep getty:

root 3220 0.0 0.0 17688 1592 tty2 Ss+ 09:59 0:00 /sbin/agetty --noclear tty2 linux
root 26984 0.0 0.0 17688 1696 tty1 Ss+ 11:01 0:00 /sbin/agetty --noclear tty1 linux

I have actually tried installing the following the systemd acpi_callGUI from marcoDallas (https://github.com/marcoDallas/acpi_call_GUI_systemd)

I try to deactivate the discrete card at boot. Upon reboot, I login to tty1 and It seems to work for a while. But when i try to switch back to the virtual terminal tty1 within an hour, it freezes.

Should i blacklist radeon.

My output running ' sudo cat /sys/kernel/debug/vgaswitcheroo/switch '
displays the following:
0:DIS: :DynOff:0000:01:00.0
1:IGD:+:Pwr:0000:00:02.0

It seems the Discrete Radeon card is not totally off.

Yovan ZJW (jiabanster) said : #5

Looking at my /var/log/Xorg.0.log:

I noticed some interesting statements:
(II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
(EE) intel(0): sna_mode_shutdown_crtc: invalid state found on pipe 1, disabling CRTC:29
[dix] couldn't enable device 11

Could press CTRL + ALT + T and use a terminal..... Bit easier

Yovan ZJW (jiabanster) said : #7

I guess there is no easy solution to make the integrated graphics work at the bootup for the virtual terminal.

Yovan ZJW (jiabanster) said : #8

As intel integrated graphics driver i915 is unable to support both graphical desktop mode and virtual terminal (in case unity display manager fails), i decided to use ATI radeon module and blacklist intel i915 module in /etc/modprobe.d/blacklist.conf .

In addition i uninstalled the systemd_acpi_call_GUI which disabled the ATI graphics driver radeon.

Before rebooting, i edit the GRUB_CMDLINE_LINUX_DEFAULT to include 'radeon.dpm = 1' under /etc/default/grub to enable power management for the discrete GPU.

In Bios , i set the Graphics driver to select Discrete Graphics card,i.e., the ATI graphics card.

Right now, i am able to login to virtual Terminal and switch back to Graphical Desktop with ease.

Yovan ZJW (jiabanster) said : #9

Adding on my solution #8 , the linux kernel or other dependencies may be activating the module. Hence, i need to run 'sudo depmod -a' in addition to 'blacklist i915' in /etc/modprobe.d/blacklist.conf.

As an added precaution, i added 'modprobe.blacklist= i915' in addition to 'radeon.dpm=1' in /etc/default/grub as shown in the following default linux grub commandline :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash crashkernel=384M-:128M radeon.dpm=1 modprobe.blacklist=i915"