no root password

Asked by cannabian

when i installed ubuntu i was no asked to enter a root-passwd...
but i need the root password to do anything...

i tried:
sudo su ... requires root pasword
sudo passwd ..... requires root pasword

password-tries:
ubuntu ........ not working
default ........ not working

what should i do?
what is the root password by default?

i cant even have changed the root password becuse this requires the root password ;)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
cannabian
Solved:
Last query:
Last reply:
Revision history for this message
Best cannabian (nightkin-gmx) said :
#1

k.. solved it and changed the passwd...
dunno how.. but i got it changed..

thx to all who answered any other post that helped me^^

Revision history for this message
Jouni Karlsson (nakkel) said :
#2

The root account has been disabled in Ubuntu, and the prefered method to do tasks that require root privileges is by using sudo.
And when using sudo you need to enter your users password to the prompt.

- J

Revision history for this message
Kjell Braden (afflux) said :
#3

You should know this: (taken from "man sudo_root")

By default, the password for the user "root" (the system administrator) is locked. This means you cannot login as root or use su. Instead, the installer will set up sudo to allow the user that is created during install to run all administrative commands.

This means that in the terminal you can use sudo for commands that require root privileges. All programs in the menu will use a graphical sudo to prompt for a password. When sudo asks for a password, it needs your password, this means that a root password is not needed.

To run a command which requires root privileges in a terminal, simply prepend sudo in front of it. To get an interactive root shell, use sudo -i.

Revision history for this message
Alan Pope 🍺🐧🐱 πŸ¦„ (popey) said :
#4

This is explained at the following page:-

http://wiki.ubuntu.com/RootSudo

Revision history for this message
Bagoes (db84x) said :
#5

i already type sudo on windows terminal but pasword keep bugging me, it really make me frutaste

Revision history for this message
luke (jone475) said :
#6

i have a use lap top with windows xp pro in it when it boot up it has ascreen name in it this is a dell laptop latitude cpi it gives a number a366xt. i don't have a cd please help me . thanks luke

Revision history for this message
Kjell Braden (afflux) said :
#7

luke, this has nothing to do with the original question.
In case you want to obtain ubuntu cds, please check http://www.ubuntu.com/getubuntu
In case you have a different question, please open a new support request at https://answers.launchpad.net/ubuntu/+addquestion

Thanks,

Revision history for this message
ibmohn (ibmohn) said :
#8

I did following

login as user and user password
the only one on the system

then I wrote
sudo -s <enter>
and came into root

there I wrote
passwd root
and vupti it answers with
write unix password and I wrote the password i like and have to rewrite it

and it chanced to what i wrote

thats it

BR Ib Mohn