can't save edited modprobe.d/options

Asked by jbryan09 on 2009-03-06

I'm trying to install a Verizon USB modem on Ubuntu 8.04. During the process I have to edit /etc/modprobe.d/options. However, when I go to save the file, the editor states I don't have the permission to edit it. I've opened terminal and tried both gksudo gedit and then the filename; sudo su followed by nano and then filename, and even gedit while acting as superuser in terminal. All options yield the same results. I'm still fairly new to linux, so if anyone could give me a pushg in the right direction, I'd appreciate it.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
peter b
Solved:
2009-03-06
Last query:
2009-03-06
Last reply:
2009-03-06
jbryan09 (xx-1100-xx) said : #1

To recap, I've tried:

-gksudo gedit /etc/modprobe.d/options
-sudo su
-nano /etc/modprobe.d/options
-gedit /etc/modprobe.d/options (after becoming superuser)

Each time I'm told I don't have permission to save after editing

Best peter b (b1pete) said : #2

try

gksu gedit /etc/modprobe.d/options

or

sudo /etc/modprobe.d/options

after each cmd above pls enter your password when prompted.

peter b

peter b (b1pete) said : #3

sorry it should have been

sudo gedit /etc/modprobe.d/options

peter

jbryan09 (xx-1100-xx) said : #4

Thanks peter b, that solved my question.

jbryan09 (xx-1100-xx) said : #5

I had to use gksu gedit /etc/modprobe.d/options to get it working. Thanks again

peter b (b1pete) said : #6

you're welcome.
petr b