WiFi is not connecting to networks on Ubuntu on ASUS A6Km

Asked by adelante on 2007-05-09

Just installed fresh Ubuntu 7.04 for 64bit AMD and Intel computers to my ASUS A6Km notebook (AMD Turion 64 1500MHz, 512 RAM, Geforce 7300, 60 HDD)

Right now I'm sitting in a cafe where is free wifi and I can't connect to it. I'm not shure if I even can locate it (BTW, how can I scan wifi nets in ubuntu?), in spite of that system tells that network adapter is working OK. When I try to connect to the network using "connect to other network" option from the connection manager, it tryes a while and then returns to start (no network connection).

Earlier this morning I tried to connect to my friends inhome Ad-Hoc WiFi net - I got the same results.

I'm new to ubuntu and I had a little experience in Linux.

Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Massimo Forti
Solved:
2007-05-16
Last query:
2007-05-16
Last reply:
2007-05-15
adelante (roman-reimkhe) said : #1

I also checked compatibility on ASUS A6km, it is reportet here of no problems using wifi.

What network card is it?

The following command will list devices in the machine.

lspci

Can you run that via a terminal and paste the result here.

adelante (roman-reimkhe) said : #3

Here it is... plus bonus (iwconfig and ifconfig):

adelante@adelante-ubuntu:~$ lspci

00:00.0 Host bridge: Silicon Integrated Systems [SiS] Unknown device 0756 (rev 02)

00:01.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge

00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] (rev 36)

00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)

00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)

00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)

00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)

00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)

00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)

00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller

00:09.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev

02)

00:0a.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)

00:0a.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)

00:0a.2 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 17)

00:0a.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 08)

00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map

00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller

00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control

01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 110M / GeForce Go 7300 (rev a1)

adelante@adelante-ubuntu:~$ iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11b/g ESSID:"" Nickname:"Broadcom 4318"

          Mode:Managed Access Point: Invalid

          RTS thr:off Fragment thr:off

          Link Quality=0/100 Signal level=-256 dBm Noise level=-256 dBm

          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

adelante@adelante-ubuntu:~$ ifconfig

eth0 Link encap:Ethernet HWaddr 00:15:F2:92:36:B1

          UP BROADCAST MULTICAST MTU:1500 Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

          Interrupt:19 Base address:0xcc00

eth0:avah Link encap:Ethernet HWaddr 00:15:F2:92:36:B1

          inet addr:169.254.7.253 Bcast:169.254.255.255 Mask:255.255.0.0

          UP BROADCAST MULTICAST MTU:1500 Metric:1

          Interrupt:19 Base address:0xcc00

lo Link encap:Local Loopback

          inet addr:127.0.0.1 Mask:255.0.0.0

          inet6 addr: ::1/128 Scope:Host

          UP LOOPBACK RUNNING MTU:16436 Metric:1

          RX packets:18 errors:0 dropped:0 overruns:0 frame:0

          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:1332 (1.3 KiB) TX bytes:1332 (1.3 KiB)

P.S. To post it here, I created this listing under ubuntu, then logged into winXP, formatted the file so it could be normally read and then posted.

You have a broadcom 43xx based wifi chipset device. Check this page for instructions on getting it working.

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

adelante (roman-reimkhe) said : #5

reading all this, I have a question: how do I know what I use: Edgy, Dapper or Breezy?

Massimo Forti (slackwarelife) said : #6

Do you want to know your Ubuntu version, open a shell and do:

$: gedit /etc/issue

thanks

adelante (roman-reimkhe) said : #7

"Ubuntu 7.04 \n \l" is written there what does that mean?

Cesare Tirabassi (norsetto) said : #8

Feisty.

Cesare Tirabassi (norsetto) said : #9

I didn't read it in detail, but I expect that the guide for Edgy applies to Feisty too. Let us know if you stumble against something which doesn't seem to work.

adelante (roman-reimkhe) said : #10

OK, Thanks to Alan Pope, https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx regarding to Edgy - fixed the problem - now my wifi finds wifi network and connects to it.

But inet is still not working. I have connected to wifinet, without any poblems, but I cant use internet. ping anything returns "network not functioning". At first I thought that it is a network's problem, not mine. I logged into winXP, connected to that network and here everything is fine.

What next to do to get it working?

Massimo Forti (slackwarelife) said : #11

After you connect you wi-fi with access point, opena shell and do:

$: iwconfig

Post the result. Thanks

adelante (roman-reimkhe) said : #12

adelante@adelante-ubuntu:~$ ping 212.44.131.6
 [it is one of my DNS servers in this net]
connect: Network is unreachable

adelante@adelante-ubuntu:~$ ping wifi.spb.gldn.net
 [it is «search domain» in this net]
ping: unknown host wifi.spb.gldn.net

adelante@adelante-ubuntu:~$ ping launchpad.net

ping: unknown host launchpad.net

adelante@adelante-ubuntu:~$ iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11b/g ESSID:"Golden_WiFi" Nickname:"Broadcom 4318"

          Mode:Managed Frequency=2.412 GHz Access Point: 00:19:E1:01:20:C0

          Bit Rate=11 Mb/s Tx-Power=19 dBm

          RTS thr:off Fragment thr:off

          Link Quality=76/100 Signal level=-42 dBm Noise level=-72 dBm

          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
g
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

adelante@adelante-ubuntu:~$ ifconfig

eth0 Link encap:Ethernet HWaddr 00:15:F2:92:36:B1

          UP BROADCAST MULTICAST MTU:1500 Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

          Interrupt:19 Base address:0xcc00

eth1 Link encap:Ethernet HWaddr 00:15:F2:8D:B4:5E

          inet addr:172.31.7.222 Bcast:172.31.7.255 Mask:255.255.248.0

          inet6 addr: fe80::215:f2ff:fe8d:b45e/64 Scope:Link

          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

          RX packets:2 errors:0 dropped:0 overruns:0 frame:0

          TX packets:173 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:1180 (1.1 KiB) TX bytes:11888 (11.6 KiB)

          Interrupt:11

lo Link encap:Local Loopback

          inet addr:127.0.0.1 Mask:255.0.0.0

          inet6 addr: ::1/128 Scope:Host

          UP LOOPBACK RUNNING MTU:16436 Metric:1

          RX packets:25430 errors:0 dropped:0 overruns:0 frame:0

          TX packets:25430 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:2078596 (1.9 MiB) TX bytes:2078596 (1.9 MiB)

And also "ipconfig /ALL" from WinXP connected and working in this net:

C:\Documents and Settings\Владелец>ipconfig /all

Настройка протокола IP для Windows

        Имя компьютера . . . . . . . . . : ROMA
        Основной DNS-суффикс . . . . . . :
        Тип узла. . . . . . . . . . . . . : неизвестный
        IP-маршрутизация включена . . . . : нет
        WINS-прокси включен . . . . . . . : да
        Порядок просмотра суффиксов DNS . : wifi.spb.gldn.net

Беспроводное сетевое соединение - Ethernet адаптер:

        DNS-суффикс этого подключения . . : wifi.spb.gldn.net
        Описание . . . . . . . . . . . . : Сетевой адаптер ASUS 802.11g
        Физический адрес. . . . . . . . . : 00-15-F2-8D-B4-5E
        Dhcp включен. . . . . . . . . . . : да
        Автонастройка включена . . . . . : да
        IP-адрес . . . . . . . . . . . . : 172.31.7.222
        Маска подсети . . . . . . . . . . : 255.255.248.0
        Основной шлюз . . . . . . . . . . : 194.31.0.1
        DHCP-сервер . . . . . . . . . . . : 10.4.242.2
        DNS-серверы . . . . . . . . . . . : 212.44.131.6
                                            212.44.130.6
        Аренда получена . . . . . . . . . : 12 мая 2007 г. 17:54:23
        Аренда истекает . . . . . . . . . : 12 мая 2007 г. 18:54:23

Подключение по локальной сети - Ethernet адаптер:

        Состояние сети . . . . . . . . . : сеть отключена
        Описание . . . . . . . . . . . . : Realtek RTL8169/8110 Family Gigabit
Ethernet NIC
        Физический адрес. . . . . . . . . : 00-15-F2-92-36-B1

(sorry for russian letters, but I think everything should be understandable)

Best Massimo Forti (slackwarelife) said : #13

Can I ask if you have enabled your mac address in your AP. I seems your wi-fi device does not approach to AP. Thanks

adelante (roman-reimkhe) said : #14

AP = access point?

How can I check it?

blixo (acleator) said : #15

Hello,

Newbie here. I was wondering if someone can help?

I have the Wi FI card working. But how do I get it to start automatically? at the moment I have to use the sudo modprobe bcm43xx command I'm running Fiesty 7.04.